<img>'s usemap attribute does not recognize map id attributes

RESOLVED DUPLICATE of bug 109445

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 109445
12 years ago
12 years ago

People

(Reporter: R. Bemrose, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The following code creates a map without any links.

<img src="bartop.jpg" border="0" usemap="#bartop" height="78" width="200" alt="Return Home" />

<map id="bar">
	<area shape="rect" href="controller.html" coords="91, 64, 196, 82" alt="MIDI Controller Map" />
	<area shape="rect" href="gminstrument.html" coords="86, 84, 196, 102" alt="GM/GM2 Tone Map" />
	<area shape="rect" href="gsinstrument.html" coords="86, 103, 196, 122" alt="GS Tone Map" />
	<area shape="rect" href="mtinstrument.html" coords="72, 125, 196, 140" alt="MT32/CM64 Tone Map" />
</map>

<img src="audiocharts.jpg" border="0" usemap="#bar" height="160" width="200" alt="Navigational Imagemap" />

The page this code is on passes the w3 validator's code as being valid XHTML 1.0 Transitional ( http://validator.w3.org/check?uri=http%3A%2F%2Fwww.voidaudio.net%2Fpercussion.html ).  This code works correctly in Internet Explorer 6 and Opera 9.

Reproducible: Always

Steps to Reproduce:
1. Make map tag with id attribute but no name attribute
2. Make img tag with usemap pointing to the map tag's id


Actual Results:  
The image renders, but the entire image map area has the link mouse pointer.  Clicking anywhere on the image does not take one to a new page.  The status bar has no url in it.

Expected Results:  
Only areas of the image corresponding to area tags should have the link mouse pointer.  Clicking a section of the image should bring you to the page referenced in the area tag.

*** This bug has been marked as a duplicate of 109445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.