check for updates menu item disabled.

RESOLVED DUPLICATE of bug 318855

Status

()

RESOLVED DUPLICATE of bug 318855
13 years ago
10 years ago

People

(Reporter: demanl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

MAC OS X 10.4.6

If you are not logged in as the user who installed firefox, the menu option "Check for Updates" is disabled.

The only way to update the software is to remove the current install by deleting the firefox.app file located in the Applications folder.  Then re-install..making sure you are logged in using the correct user(admin) account.

Then when using your correct(desired) user account..you can run the "Check for Updates" menu option.

The application should be able to check for updates automatically and manually while logged into the mac os x computer using an user account that has adminstrative privileges on the computer.   If a managed user account is used, then these features should be disabled.

Reproducible: Always

Steps to Reproduce:
1.create two administrative accounts, adminA and adminB.
2.log on as adminA and install firefox into the Applications folder, verify firefox works, then log off.
3.log on as adminB and verify that firefox works.
4.check to see if the menu option "Check for Updates" is available and see if it works....at this point is where I see that it is disabled.
Forgive my ignorance of things Mac, but why do the two admin accounts not have write access to each other's files ? Does Mac have a different definition of Admin than Windows (Administrator group members) or Linux (root) ? 
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Forgive my ignorance of things Mac, but why do the two admin accounts not have
> write access to each other's files ? Does Mac have a different definition of
> Admin than Windows (Administrator group members) or Linux (root) ? 
> 

I'm also new to osx and linux....and it would seem that two different admin accounts do not have access to each other's folders in osx....:(

Comment 3

12 years ago
Dupe of bug 318855?

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 318855 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.