printing and print preview: printing doesn't print form inputs

NEW
Unassigned

Status

()

Core
Printing: Output
12 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

printing and print preview:  printing doesn't print form inputs

but unlike that old bug, print preview doesn't show the form inputs either!

I'll attach a screen shot.

this is trunk only.  I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060629 Minefield/3.0a1

see also bug #267352
Created attachment 227823 [details]
screen shot, print preview on top, browser on bottom
Component: General → General
Product: Firefox → Core
Component: General → Printing

Comment 2

12 years ago
Dupe of bug 340564?
It selects "Reassign bug to default assignee and QA contact of selected component" or it gets the hose again.
Assignee: nobody → printing
QA Contact: general
Depends on: 340564

Comment 4

9 years ago
I would like to confirm that I see this bug under MacOS X, using the latest Shiretoko nightly build.

Comment 5

9 years ago
I am also having printing problems in Thunderbird version 2.0.0.21 and/or
2.0.0.22 (Mac OSX 10.5.7). When printing, not all of the content on page is
printed, it cuts off part of the message body from bottom of page two.  Huge
white space with email header info (TO, From, Subj, etc.,) then the remaining of
page is blank on page one.  page 2 preview displays the message body (which is validated HTML
email)<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
        "http://www.w3.org/TR/html4/loose.dtd"> but cuts off the content
not able to be display on a single printed page. Page three prints the footer
of the html page without the remaining text from previous page. I upgraded to (latest)Thunderbird V 2.0.0.22 with no better
results.
The same email was sent from another source to two email addresses, one I check with Thunderbird - resulting in missing data (only when preview or printing), and another opened in Apple Mail. This prints 100% correctly. Something definitely wrong w/ Thunderbird.  I am able to reproduce this on multiple Macs w/ Thunderbird.
humm...  I'd hate to switch to Apple Mail.  Anything.... anybody....help!

Comment 6

9 years ago
Created attachment 391146 [details]
Thunderbird version 2.0.0.22 (20090605) print preview bug

Screen shot attached from HTML email in preview (Mac OSX 10.5.4) Thunderbird version 2.0.0.22 (20090605). Apple Mail does not have this preview/printing problem, identical email message.
Comment on attachment 391146 [details]
Thunderbird version 2.0.0.22 (20090605) print preview bug

Mac: That's a completely different problem from what this bug is about (printing blank form inputs).  Let's please keep each bug focused on one specific issue.

Having said that, I don't think Thunderbird 2.0.0.x is accepting any patches other than security fixes, at this point, so it's highly doubtful that either issue will be fixed in a Thunderbird 2.0.0.x update.

However, Thunderbird 3 is on the horizon -- if you can reproduce your issue in the latest Thunderbird 3 Beta ( http://www.mozillamessaging.com/en-US/thunderbird/early_releases/ ), or in Firefox > 3.5 (after saving the email as a HTML document), then please file a *new* bug on the issue that you describe.

Thanks!
Attachment #391146 - Attachment is obsolete: true
Assignee: printing → nobody
QA Contact: printing
You need to log in before you can comment on or make changes to this bug.