mousemove no longer functions with very large rectangles

RESOLVED FIXED

Status

()

Core
SVG
--
minor
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: k_lindsey, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

It looks like there is a potential overflow issue with x,y,width,height when defining rectangles (I did not try other shapes). If these values become too large, mousemove event handlers associated with that shape no longer fire.

Reproducible: Always

Steps to Reproduce:
1. define a large rectangle and its associated mousemove handler like so:
    <rect x="-32767" y="-32767" width="65535" height="65535"
          fill="green" pointer-events="fill" onmousemove="update(evt)"/>

2. save as an SVG file
3. open the SVG file
4. move the mouse over green shape

Actual Results:  
The "update" function never fires.

Expected Results:  
Expected "update" function to fire

If you decrease the values used in the rectangle above, the mousemove event will fire. For example, the following definition will work correctly:
    <rect x="-16384" y="-16384" width="32767" height="32767"
          fill="green" pointer-events="fill" onmousemove="update(evt)"/>
(Reporter)

Comment 1

12 years ago
Created attachment 227826 [details]
Large rectangle does not fire mousemove events

The circles should respone to mousemove events. Uncomment the commented out <rect> and then comment out the following <rect>. Reopen the file and now the circles will respond to mousemove events.
I think this is probably a duplicate of bug 315383.
Attachment #227826 - Attachment mime type: image/xml+svg → image/svg+xml

Comment 3

11 years ago
Also look at Bug 381875
Fixed by check in for bug 384681
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.