Closed Bug 343354 Opened 14 years ago Closed 13 years ago

cygwin-wrapper should support resolving /tmp

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 207521

People

(Reporter: WeirdAl, Assigned: WeirdAl)

Details

Attachments

(1 file)

Patch forthcoming.  I found out I couldn't cleanly use /tmp as an argument passed through cygwin-wrapper to xpidl.
This patch gathers where the / directory lives through mount, and then substitutes $root/tmp for /tmp at the beginning of the argument.

If it's not accepted, that's fine.  This is a suggestion only.
Attachment #227836 - Flags: review?(cls)
Comment on attachment 227836 [details] [diff] [review]
patch enabling /tmp substitution

$root winds up with an extra newline before the value.  That seems like it would cause a problem somewhere down the line.

If we're going to use that fallback case always, we might as well go all out and make it work for all cases (bug 207521).
Attachment #227836 - Flags: review?(cls) → review-

*** This bug has been marked as a duplicate of 207521 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.