Crash during loading of http://acornweb.org [@ nsHTMLReflowState::InitConstraints]

RESOLVED INVALID

Status

()

Core
Layout
--
critical
RESOLVED INVALID
12 years ago
7 years ago

People

(Reporter: Moses Lei, Unassigned)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2

Camino crashes on this page. It starts to load it and then crashes. Firefox, Shiira, etc are fine. This happens on both 1.0.2 and the latest nightly. The page has a java applet and possibly other embedded objects.

Crash Reporter logs for both:

The first is 1.0.2, second is nightly. I have nothing in the Internet Plug-Ins folder.

**********

Host Name:      brahms
Date/Time:      2006-07-01 22:47:26.853 -0400
OS Version:     10.4.5 (Build 8H14)
Report Version: 4

Command: Camino
Path:    /Applications/Camino.app/Contents/MacOS/Camino
Parent:  WindowServer [63]

Version: 1.0.2 (1.0.2)

PID:    8100
Thread: Unknown

Link (dyld) error:

no suitable image found.  Did find:
	/Library/Internet Plug-Ins/AdobePDFViewer.plugin: not a file
**********

Host Name:      brahms
Date/Time:      2006-07-01 22:52:19.036 -0400
OS Version:     10.4.5 (Build 8H14)
Report Version: 4

Command: Camino
Path:    /Applications/camino nightly/Camino.app/Contents/MacOS/Camino
Parent:  WindowServer [63]

Version: 1.0+ (1.0+)

PID:    8130
Thread: Unknown

Link (dyld) error:

no suitable image found.  Did find:
	/Library/Internet Plug-Ins/AdobePDFViewer.plugin: not a file

Reproducible: Always

Steps to Reproduce:
1. Open Camino.
2. Type http://acornweb.org into the address box.
Actual Results:  
Crash.

Expected Results:  
Load the page.

I believe these talkback incidents TB20211776Y and TB20345773M are this same crash. For some reason when I went back to do the testing this time, talkback didn't pop up. I'll try it again and see if I can get another Talkback incident.
(Reporter)

Comment 1

12 years ago
Only the second of the above talkback incidents (TB20345773M) is related to this bug. Sorry for the mistake.
That page looks like it has Flash, not Java.  I also can't cause it to crash on 1.0.2 or the 18branch on 10.3.9 with Flash 8.0 r24.

Your Talkback report for that page wasn't useful, just like the Mac OS X crash log :-(

Can you remove the /Library/Internet Plug-Ins/AdobePDFViewer.plugin from /Library/Internet Plug-Ins/ and try the page again to see if Camino crashes with a more useful Mac OS X crash log?  If so, *attach* the crash log using the "Create a New Attachment" above.

Comment 3

12 years ago
(In reply to comment #0)
> I have nothing in the Internet Plug-Ins folder.

That sounds like you are looking in the "~/Library/Internet Plug-Ins" folder (the one in your home directory), not the "/Library/Internet Plug-Ins" folder (the one at the root of your boot volume), since there are a bunch of plugins there on a stock system.  The AdobePDFViewer.plugin mentioned in the crash log will be in the one at the root of your volume.
(Reporter)

Comment 4

12 years ago
> That sounds like you are looking in the "~/Library/Internet Plug-Ins" folder
> (the one in your home directory), not the "/Library/Internet Plug-Ins" folder
> (the one at the root of your boot volume), since there are a bunch of plugins
> there on a stock system.  The AdobePDFViewer.plugin mentioned in the crash log
> will be in the one at the root of your volume.
> 
Ugh, thanks for that, I'm not sure how I missed that. Of course it would be the one in root...

And yes, the crash log seems to be much more useful this time. Attaching.
(Reporter)

Comment 5

12 years ago
Created attachment 227861 [details]
Log from crashreporterd
Do you have a Talkback # for the crash corresponding to that log?  We really need a non-corrupted top frame here :-(  Talkback might have captured it (but may not have; one never can tell)....

Comment 7

12 years ago
what was provided is fairly good, the top stack frame isn't corrupted, although having talkback would be quite helpful....
Component: Plug-ins → Layout
Keywords: crash
Product: Camino → Core
QA Contact: plugins → layout
Summary: Crash during loading of http://acornweb.org → Crash during loading of http://acornweb.org [@ nsHTMLReflowState::InitConstraints]
Version: unspecified → 1.8 Branch
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> what was provided is fairly good, the top stack frame isn't corrupted, although
> having talkback would be quite helpful....
> 

For some reason, Talkback isn't triggering on the crash anymore-- it did before, I'm not sure why it doesn't now. Talkback doesn't seem to be in the nightly builds, is there a build that has it?
Component: Layout → Plug-ins
Product: Core → Camino
Version: 1.8 Branch → Trunk
(Reporter)

Updated

12 years ago
Component: Plug-ins → Plug-ins
Product: Camino → Core
(Reporter)

Updated

12 years ago
Component: Plug-ins → Layout
(Reporter)

Updated

12 years ago
Version: Trunk → 1.8 Branch
(Reporter)

Comment 9

12 years ago
Turned out to be a bad extension-- an old version of CamiFlash. I updated to the new version and it's fine. Thanks everyone for looking at this and giving me the clues to find the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsHTMLReflowState::InitConstraints]
You need to log in before you can comment on or make changes to this bug.