style 'width' has no effect to <input type="file">

RESOLVED DUPLICATE of bug 52500

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 52500
12 years ago
12 years ago

People

(Reporter: Ronald.Koehler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060209 Debian/1.5.dfsg+1.5.0.1-2 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.1) Gecko/20060209 Debian/1.5.dfsg+1.5.0.1-2 Firefox/1.5.0.1

I think there is a problem with the style (CSS) attribute 'width'. Firefox and Mozilla ignore this for HTML tag '<input type="file">'. (For '<input type="text"> it's ok)

Reproducible: Always

Steps to Reproduce:
example:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <title>Layout check</title>
  </head>
  <body style="background-color: #8080a0">
    <h1 align="center">Layout check</h1>
    <table style="width: 100%" border="1">
      <tr><td>Text:</td>
          <td><input type="text" style="width: 100%"></td></tr>
      <tr><td>File:</td>
          <td><input type="file" style="width: 100%"></td></tr>
    </table>
  </body>
</html>





test environment:

PC - Linux (Debian Sarge) - Firefox (1.5.0.1)
PC - Linux (Debian Sarge) - Mozilla (1.7.12)
PC - Windows XP - Firefox (1.5.0.4)

in comparison:

PC - Linux (Debian Sarge) - Konqueror (3.5.1)
PC - Linux (Debian Sarge) - Opera (8.5)
PC - Windows XP – Internet Explorer (6.0.2900.2180)

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.