Seamonkey crashes when trying to run mail application [@ nsXULPrototypeAttribute::Finalize]

VERIFIED DUPLICATE of bug 341595

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 341595
12 years ago
12 years ago

People

(Reporter: Alexander Rabtchevich, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060630 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060630 SeaMonkey/1.5a

All the latest buuilds have the same problem: if the suite has some problems and it is restarted, trying to get mail (window->mail or the icon at the bottom) crashes the suite. Reinstallation of the suite cures the situation untill next crash.

See crash reports No
TB20568663X, TB20549443Y, TB20549425Q, TB20542491M, TB20535656G, TB20512009E, TB20511985H
Some previous ones exist too.

This is connected with the old bug: if the suite had some problems connecting to some host, it didn't load the page untill it had been restarted. The status bar wrote "Stopped" and no reloading helped. Now it seems reloading starts helping. But another problem arose: the mail reject to run after the suite has been restarted.


Reproducible: Always

Steps to Reproduce:
1. Get the suite not to load some page. Maybe hard to reproduce - I guess it's connected with bad connection and returned packets.
2. Restart the suite.
3. Ask for mail.

Actual Results:  
The suite crashes. Restarting doesn't help, only reinstallation.

Expected Results:  
Working application.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 341595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 2

12 years ago
Incident ID: 20511985
Stack Signature	nsXULPrototypeAttribute::Finalize a1b828f9
Product ID	MozillaTrunk
Build ID	2006063008
Trigger Time	2006-07-02 10:09:13.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	gklayout.dll + (001c0ecc)
URL visited	
User Comments	
Since Last Crash	5 sec
Total Uptime	2147 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp, line 2481
Stack Trace 	
nsXULPrototypeAttribute::Finalize  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp, line 2481]
nsXULDocument::LoadOverlayInternal  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2586]
nsXULDocument::ResumeWalk  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2914]
nsXULDocument::CachedChromeStreamListener::OnStopRequest  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp, line 4201]
nsCachedChromeChannel::HandleStopLoadEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp, line 446]
NS_ProcessPendingEvents_P  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsThreadUtils.cpp, line 182]
nsWindow::DispatchPendingEvents  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 4066]
nsWindow::WindowProc  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
USER32.dll + 0x8734 (0x77d38734)
USER32.dll + 0x8816 (0x77d38816)
USER32.dll + 0x89cd (0x77d389cd)
USER32.dll + 0x8a10 (0x77d38a10)
nsAppShell::ProcessNextNativeEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp, line 152]
nsBaseAppShell::DoProcessNextNativeEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp, line 137]
0xc0850845
Severity: normal → critical
Keywords: crash
Summary: Seamonkey crashes when trying to run mail application → Seamonkey crashes when trying to run mail application [@ nsXULPrototypeAttribute::Finalize]
Version: unspecified → Trunk
Crash Signature: [@ nsXULPrototypeAttribute::Finalize]
You need to log in before you can comment on or make changes to this bug.