Bookmarks Toolbar dropdown glitches when you drag bookmarks within it

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
In the bookmarks toolbar, if you have too many bookmarks, it overflows with a dropdown menu at the right. 

If you open this up, and click one and drag, you can reorder bookmarks in it. However, when you do this, it then displays *all* the bookmarks from the toolbar in the menu.

Note that sometimes it flashes and then closes itself, while sometimes it stays open.
Related to / variant of Bug 331297 or is it more recent?

Comment 2

12 years ago
Steps to reproduce:
1. Get enough bookmarks in the Bookmarks Toolbar so you see the chevron.
2. Open the dropdown menu and and click and drag a bookmark to another place in the dropdown.

Results:
After you release the drag the entire contents of the Bookmarks Toolbar will show up in the dropdown.

Probably the same core issue as bug 331297.
Depends on: 331297

Comment 3

12 years ago
I see this on Mac, too, though the menu only seems to be expanded for an eyeblink. Also annoying is the fact that when I drop the bookmark during moving, it starts to load it in the active tab, so two things are grabbing the drop. But that's probably a separate bug.
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 4

10 years ago
This got fixed at some point.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.