print outs scaled to a quarter of the size it should be...shows up tiny in print preview as well

RESOLVED INVALID

Status

()

Core
Printing: Output
--
major
RESOLVED INVALID
12 years ago
8 years ago

People

(Reporter: Wholesale Stop Online . com, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

I found this problem when using paypal.com...all of their pages, when printing from firefox, print out about a quarter of the size it should.  The entire page prints out, but it is only printed in the upper left corner of the paper.  Using Internet Explorer, it prints out in full.  It doesn't happen with all websites I to print.  It happens with paypal.com and ebay.com, but not mozilla.org, wholesalestoponline.com, or amazon.com.  
If a fix becomes available, please let me know...for now I am stuck using internet explorer when I need to print out postage labels from paypal.

Reproducible: Always

Steps to Reproduce:
1. go to paypal.com or ebay.com
2. print preview
3. print

Actual Results:  
print preview looks scaled to one quarter, print out is tiny like preview.

Expected Results:  
print out should have filled entire page, not one quarter of the blank page.

I am using a Sony Vaio with windows xp sp2, and print to an epson stylus c86.  The websites that experienced this problem when being printed in firefox, printed out correctly in IE.
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch

Comment 1

12 years ago
Is there some page you can link to directly which shows this problem?

In Page Setup, what is your scale set to?  Or do you have shrink to fit on?

If you change the scale to 100% in Print Preview, does it look any different?  (If it's already at 100%, try switching to something else and back to 100%).

Comment 2

11 years ago
Created attachment 249060 [details]
scanned printed output, showing the problem

Comment 3

11 years ago
Created attachment 249064 [details]
Screenshot of the print preview.

Firefox appears to be formatting for a page much smaller than the letter size I'm printing to...  But I can find no way to set the page size.

Comment 4

11 years ago
(Hmm, entered a bunch of comments, but they seem to have vaporized when I did the attachments.  I'll try again.  Hope this isn't redundant.)
Printed output is limited to the upper-left quadrant of the page.  Content is clipped.  Happens reproducibly for *ALL* web pages.  Output is sometimes tiny, but not always. I began seeing the problem with 1.5(07?), still there with 2.0.  I've done a complete uninstall and reinstall, no help.
Win XP sp2.  Page setup: portrait, 100% (tried scale-to-fit, 200%, etc, nothing works), print backgrounds is on, margins:0, headers and footers blank.
Scanned printed output for the first printed page of this report page attached.

Comment 5

11 years ago
When you go to File, Print..., Properties, is there a paper size setting?  Is it set to correspond to the paper in your printer?

Comment 6

11 years ago
Ah, thanks Eli.  Yes, at some point in time I had set media size to 4x6 and this was my problem.
I find it counter-intuitive that this setting is sticky across documents and even across installs.  It never occurred to me to check the printer settings; I just assumed it was using my Windows default print settings.
And it seems problematic that keeping these settings sticky effectively causes them to behave as !important instructions.  When the page styling specifies that it should be printed on a particular size, those instructions are ignored and output is formatted for the remembered settings.
I would suggest that, in the absence of support for the @page size construct, or in the absence of such instructions, the user's default print settings should be used rather than the settings chosen the last time a document was printed.  This would lead to fewer printing frustrations.

Comment 7

10 years ago
I saw similar behavior with every website including google maps,
starting when I installed FF-3.0beta5 or rc1.  I found this in
about:config :

print.printer_hp_LaserJet_1012.print_scaling;  0.30

Changing it to 1.00 restored the correct behaviour.  I don't know how
print.*.print_scaling got changed to 0.30

It seems that this bug is always due to some sort of user error, and
should maybe be closed as INVALID.
Assignee: printing → nobody
QA Contact: printing

Comment 8

8 years ago
invalid.
but if anyone sees it differently, please comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.