CSS code associated with h2 tags is inconsistent when page is printed

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Marc Drumm, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Throughout my site, certain h2 tags are supposed to show a dashed line below their text when they are associated with one of a few different classes.  These dashed lines all show properly on the screen, but when the page is printed (either when previewing the print, or actually printing it out) they are occasionally missing.  The site uses different CSS files for screen and print, but these code for these h2 classes is identical in both files.  All XHTML and CSS code validates without error.

Screen CSS: http://www.udel.edu/bio/common/common8020.css
Print CSS: http://www.udel.edu/bio/common/print8020.css

This problem occurs in the Mac version of Firefox, but not the Windows version.  It is reproducible on different Macs, and it does not occur in Safari 2.0.4 or Opera 9.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.udel.edu/bio/ed/undergrad/degrees/cmg.html
2. Select File > Print...
3. Click either the Print or Preview button
Actual Results:  
In the main text of the page, notice that there are dashed underlines on the screen for roman numerals I. through VI. (which there should be as defined by the CSS code), but they are missing for V. and VI. in the Print/Preview version.

Expected Results:  
The dashed underlines should appear for roman numerals I. through VI.

I can provide URLs for other pages in the site that cause this bug to appear if needed.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

11 years ago
Yes, I'm afraid the problem still exists in Firefox 2.0.0.4 for Mac.

Updated

11 years ago
Component: General → Printing
Product: Firefox → Core
QA Contact: general → printing
Whiteboard: CLOSEME 06/27
Version: 1.5.0.x Branch → 1.8 Branch
(Reporter)

Comment 3

10 years ago
This issue has been fixed in Firefox 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.