Registration at addons.mozilla.org fails if one requests reset password e-mail before activating account.

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Administration
--
major
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: Siarhei Vaurynovich, Assigned: clouserw)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4




Reproducible: Didn't try

Steps to Reproduce:
1. I registered at addons.mozilla.org
2. Before I received the activation e-mail I requested a "reset password" e-mail.
3. Tried to activate my account.

Actual Results:  
After I did so (see "Steps to Reproduce") activation of the account fails ("There was an error activating vaurynov@mit.edu"). I am allowed to reset password but the password does not work ("You were not successfully logged in. Check your e-mail address and password and try again.") I can not recreate the account either ("The E-Mail address you entered is already in use.") So I could not find a way out of the circle.

Expected Results:  
If account was not activated yet and a user tries to request a "reset password" e-mail he/she must get an error message asking to activate the account before resetting password. 

Or (which would be even better) if an account is not activated yet and user requests a "reset password" e-mail he/she should get an activation e-mail instead.

It takes quite long time to receive *any* e-mail from you (either "activation" or "reset password") after one follows the steps described above. I tried to reproduce the problem using an other e-mail address but after ~40 min of waiting for an e-mail from from you I decided just to send what I have now.
--> Update
Component: *.mozilla.org → Developer Pages
Product: Websites → Update
QA Contact: other-mozilla-org → developers
Version: unspecified → 2.0
Component: Developer Pages → Administration
QA Contact: developers → administration

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
Hm,
I run into same problem as well. I have registered addons.mozilla.org
account today. IN fact, it was not clear for me that there will be 
"activation mail". 

I have tried to login immediately after registration. Fails... I have looked
at my mail box (predicting there will be some mail - nothing there). Then I requested 'change password'. It said it sent mail to my password. When I looked
into mail box again, I found 2 mails:
 1. password change
 2. activation

I tried to activate. It says:

--------------------------------------------------------------
Verify your Mozilla Addons Account

There was an error activating alex@koval.kharkov.ua. If the account hasn't been registered yet, please register before activating.
--------------------------------------------------------------

Attempt to follow link to change password works, all says "password changed" but I still can not login. I expect this is because account is not yet activated, and activate procedure is broken...

(Assignee)

Updated

12 years ago
Assignee: nobody → clouserw
(Assignee)

Comment 3

12 years ago
Created attachment 229904 [details] [diff] [review]
Confirm user when they change their password
Attachment #229904 - Flags: first-review?(morgamic)
(Reporter)

Comment 4

12 years ago
Guys, after you correct the bug please delete my account and all the other accounts which got stuck in the unusable state. That would allow us to recreate our accounts and start actually using them.

Thank you!!!
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> Guys, after you correct the bug please delete my account and all the other
> accounts which got stuck in the unusable state. That would allow us to recreate
> our accounts and start actually using them.
> 
> Thank you!!!
> 

My proposed patch should allow you to use the reset password link to activate your account.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Guys, after you correct the bug please delete my account and all the other
> > accounts which got stuck in the unusable state. That would allow us to recreate
> > our accounts and start actually using them.
> > 
> > Thank you!!!
> > 
> 
> My proposed patch should allow you to use the reset password link to activate
> your account.
> 
Unfortunately, I still can not neither activate my account nor log in. What I tried to do:

1) Followed my password reset link:

   https://addons.mozilla.org/recoverpassword.php?email=vaurynov@mit.edu

2) Reset "successfully" password using the link in the e-mail.

3) Tried to log in. Got just the same error message as before:

   "You were not successfully logged in. Check your e-mail address and password and try again. If you've forgotten your password you can recover it."

Comment 7

12 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Guys, after you correct the bug please delete my account and all the other
> > > accounts which got stuck in the unusable state. That would allow us to recreate
> > > our accounts and start actually using them.
> > > 
> > > Thank you!!!
> > > 
> > 
> > My proposed patch should allow you to use the reset password link to activate
> > your account.
> > 
> Unfortunately, I still can not neither activate my account nor log in. 
> 
Patience my friend. The patch still has to be reviewed, possibly modified and reviewed again, checked in, and then the site updated from cvs.

http://www.mozilla.org/hacking/life-cycle.html
Comment on attachment 229904 [details] [diff] [review]
Confirm user when they change their password

Looks good. FTW!
Attachment #229904 - Flags: first-review?(morgamic) → first-review+
(Assignee)

Comment 9

12 years ago
This is in CVS, will be live on the next update.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

12 years ago
This should be live.  Can anyone who was having troubles registering, go to the reset password page and try again?  

Thanks
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> This should be live.  Can anyone who was having troubles registering, go to the
> reset password page and try again?  
> 
> Thanks
>

Wil, unfortunately it does not seem to work. I have just tried to reset 
password, then loged in and got the same error message:

==================================
You were not successfully logged in. Check your e-mail address and password and try again. If you've forgotten your password you can recover it.
==================================

One thing that is strange is how the reset password result page looks like:

==================================
Your password has been reset.

      li>Login to Mozilla Add-ons 
==================================

Note the presence of "li>" which is a part of a <li> tag
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4).
(Assignee)

Comment 12

12 years ago
Siarhei Vaurynovich:

Oh, sorry.  The live site must not be updated yet, since I fixed the li> thing with the update.  It must be taking longer than usual. :(
(Assignee)

Comment 13

12 years ago
It's up to date now - we had a caching issue.  Please try again. :)

Wil
(Reporter)

Comment 14

12 years ago
(In reply to comment #13)
> It's up to date now - we had a caching issue.  Please try again. :)

I waited for a few days this time (just in case) ;) 
And this time I could log in!!! Thank you, guys, for fixing it!!!

Comment 15

12 years ago
I ran into the same issue of hitting the reset password before activating.  I was not able to log in after activation, but i was able to login after completing the reset password.  I did not receive a confirmation of my new pasword, making it certain that i will need to reset it when i get around to trying to login again.

The text on the register page could be more clear about the need to follow a link from the confirmation e-mail in order to activate the account.  I did not reach the post-registration page as i was trying to backpedal.
(Assignee)

Comment 16

12 years ago
Created attachment 231479 [details] [diff] [review]
add some text about the email

charles:  does this make it clearer?  If not, what would?
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.