Implement nsIDOM3Text::isElementContentWhitespace()

VERIFIED DUPLICATE of bug 283861

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 283861
12 years ago
7 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Wandering around our codebase, I discovered nsGenericDOMDataNode::IsOnlyWhitespace().  I think we can use this to implement nsIDOM3Text::isElementContentWhitespace().

Taking.
(Reporter)

Comment 1

12 years ago
	<WeirdAl>	http://www.w3.org/TR/2004/REC-DOM-Level-3-Core-20040407/core.html#Text3-isElementContentWhitespace - the way it's written, I think the intent was to say "Does this text node contain only whitespace?"
	<sicking>	no, it's pretty clear that it's not as simple as that

Unfortunately, it's not so clear what it *does* mean.  As I misinterpreted the spec, I'm assigning to the default owner.
Assignee: ajvincent → general
You may want to look at the patch in bug 283861, which is probably bitrotted; eventually, either this or that bug should be duped there.
(Reporter)

Comment 3

11 years ago

*** This bug has been marked as a duplicate of 283861 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general

Updated

7 years ago
Assignee: general → nobody
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.