Closed Bug 343984 Opened 18 years ago Closed 18 years ago

js1_5/Regress/regress-140852.js result: FAILED type: shell (DEBUG)

Categories

(Core :: JavaScript Engine, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: bc, Assigned: bc)

References

Details

(Keywords: regression, verified1.8.0.7, verified1.8.1, Whiteboard: [at risk])

Attachments

(4 files)

Regression from bug 336373 Debug/Windows/Shell only.

BUGNUMBER: 140852
FAILED!: String(number) = xxxx:0000 for some numbers

FAILED!: Expected value '100000000000', Actual value '0:0000000000'
FAILED!: Expected value '426067200000', Actual value '4260671:0000'
This is 1.8.1 only.
Flags: blocking1.8.1?
Flags: blocking1.8.1? → blocking1.8.1+
See bug 140852, but bug number of the regression test.  It sure sounds like the MS compiler you are using is regressed, or we lost the needed option, or its option name changed, or something like that.

/be
Blocks: 344320
I uses VC6 on the 1.8.x branches and VC8 on the trunk. Nothing changed to my build process except the parallel building and testing required by time constraints this time.
bc, try forcing -Op on in the Makefile.

/be
I can't reproduce this one either. Maybe I should just give up and quit.
I have Visual Studio 2005, /Op is no longer supported. It now uses command line option /fp:xxx. Where xxx is strict, precise, and fast. The default looks to be precise. Precise may be good enough, but if there are problems we might have to set it to strict (/fp:strict).

VC++ 6 base didn't have a problem until the processor pack service pack was installed.
This is a bug in Makefile.ref, hence a Windows js shell bug only.  Patching, but I would appreciate it if someone with a Windows box handy could test and land.  So I am not going to take ownership of this bug.

/be
Attachment #230276 - Flags: review?(bclary)
Comment on attachment 230276 [details] [diff] [review]
proposed fix to Makefile.ref

_MSC_VER isn't available in Makefile.ref so this will always use -Op.

I think we could use the output of cl to get the version number though, if you think that would be ok.

For VC8, _MSC_VER is 1400 which corresponds to 

$ cl
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.42 for 80x86
Copyright (C) Microsoft Corporation.  All rights reserved.

usage: cl [ option... ] filename... [ /link linkoption... ]

$ cl 2>&1 | grep 'Compiler Version' | sed 's/.*Compiler Version \([0-9]*\)\.\([0-9]*\).*/\1\2/'
1400
Attachment #230276 - Flags: review?(bclary) → review-
Bob, is there nothing set by vcvars32.bat or vsvars32.bat in the environment that the Makefile can test?  I seem to recall a bunch of variables set there, possibly including a version one.

Anyhoo, you, mrbkap, or another kind soul who can test on Windows (I can't until week after next) should take this bug.

/be
Attached patch patch v2Splinter Review
This works for me in VC6 and VC8.
Attachment #230289 - Flags: superreview?(brendan)
Attachment #230289 - Flags: review?(mrbkap)
Attachment #230289 - Flags: review?(mrbkap) → review+
Comment on attachment 230289 [details] [diff] [review]
patch v2

Lose the grep by using sed -n 's/.../.../p' and sr=me.

/be
Attached patch patch v3Splinter Review
this is what I'll check in. Confirmed it uses  -Op on 1.8 and -fp:precise on 1.9.
checked patch v3 into trunk.

Checking in Makefile.ref;
/cvsroot/mozilla/js/src/Makefile.ref,v  <--  Makefile.ref
new revision: 3.41; previous revision: 3.40
Comment on attachment 230688 [details] [diff] [review]
patch v3

no harm, no foul to keeping these in sync.
Attachment #230688 - Flags: approval1.8.1?
Attachment #230688 - Flags: approval1.8.0.6?
Comment on attachment 230688 [details] [diff] [review]
patch v3

a=drivers. Please land this on the MOZILLA_1_8_BRANCH.
Attachment #230688 - Flags: approval1.8.1? → approval1.8.1+
patch v3 checked into 1.8 branch
Checking in Makefile.ref;
/cvsroot/mozilla/js/src/Makefile.ref,v  <--  Makefile.ref
new revision: 3.30.22.2; previous revision: 3.30.22.1
Assignee: general → bclary
js1_5/Regress/regress-140852.js passes in windows xp opt, debug shell for 1.8, trunk. Will verify in the next test run.
Status: NEW → RESOLVED
Closed: 18 years ago
Flags: in-testsuite+
Keywords: fixed1.8.1
Resolution: --- → FIXED
verified fixed 1.8.1 windows/mac(ppc|tel)/linux 20060728
Status: RESOLVED → VERIFIED
Comment on attachment 230688 [details] [diff] [review]
patch v3

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #230688 - Flags: approval1.8.0.7? → approval1.8.0.7+
what I checked into 1.8.0
Checking in Makefile.ref;
/cvsroot/mozilla/js/src/Makefile.ref,v  <--  Makefile.ref
new revision: 3.30.28.1; previous revision: 3.30
Keywords: fixed1.8.0.7
verified fixed 1.8.0.7 20060824 window/mac*/linux
Attachment #230289 - Flags: superreview?(brendan)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: