Can't send email after saving draft then changing accounts

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Seen in both branch and nightly trunk builds this week.

This bug may be somewhat related to bug 229342 and bug 278198.

I have an NNTP news account setup with a bogus email address to avoid spam,
and (in the same profile) an email account with valid email address and 
server names.  

I wanted to forward a news message using my email account.  I followed these
steps:
 a) read a news (NNTP) message, and 
 b) click "forward" to forward it, then 
 c) write a long message to introduce the forwarded message to the intended
    recipient, then
 d) click "save" to save a draft of it (in case of a crash) in the drafts
    folder of the "local folders" account, then
 e) in the compose window, change the account with/from which the message 
    will be sent to an email (not news) account with a valid email address.
    Also enter the to/cc addresses of the intended recipients.  Then, 
 f) Click "send" to send the message, 

Got this dialog:
> > Sending of message failed.
> >
> > There was an error attaching <subject>?.eml. 
> > Please check if you have access to the file.
> >
> >                [ OK ]

I repeated all these steps many times, trying different variants, until 
I found the cause, and also found two workarounds.  

The cause was saving the draft before changing the account from which the
message would be sent.  If I do that, then I find that I cannot send the
message after changing email accounts, AND I also cannot save a draft 
after changing email accounts.  If I attempt to save another draft after
changing email accounts, then I get this dialog:

> > Unable to save your message as draft.
> > 
> > There was an error attaching <subject>?.eml. 
> > Please check if you have access to the file.
> >
> >                [ OK ]

I found two workarounds:

First workaround:
   Do step "c" before step "d".  That is, change the email account before
   composing the forward/introduction, and ESPECIALLY before saving any draft.
   If I do that, then there is no problem.  

   This is really just avoiding the problem, more than a workaround.  
   If you've already saved the draft before step e, then you need the 

First Alternative workaround: 
   At step f, when the send fails, close the composition window.  Then go to 
   the "drafts" folder of the "local folders" account, where the draft was 
   saved in step d, and select that draft.  Then click "Edit Draft". 
   Immediately proceed to step e and then step f.  It will work, although 
   the user must re-create the to/cc list in that second step e.

That alternative workaround isn't of much consolation to the poor user who 
made a lot of edits to the forward/introduction message AFTER saving the 
message in step d.  For such a user, there is the 

Second alternative workaround (sort of obvious):

   Before closing the composition window in which the send failed, copy all
   the text from that composition window to another text window (e.g. to 
   a notepad window or another new email composition window).  Then start 
   over, doing steps a, b and e over again.  Then restore the text of the 
   introductory message (saved just above), and send the result.

Comment 1

10 years ago
Nelson, do you still see this problem?
WFM TB version 3.0a2pre (2008052103)
(Reporter)

Comment 2

10 years ago
I tried to reproduce it today with Gecko/2008052802 but could not.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.