going back to home page in antiphishing breaks if multiple tab homepage is set

RESOLVED FIXED in Firefox 2

Status

()

Toolkit
Safe Browsing
P1
normal
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: chaseslabaugh, Assigned: Gavin)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch in 339032])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1

If you go to a site that is suspected for phishing, and then click Get me out of here! to leave, if your homepage contains tabs, such as mine (http://slashdot.org/|http://digg.com/), then it will attempt to navigate to that site, i.e. going to the nonexistent slashdot directory |http://digg.com, instead of opening 2 tabs.

Reproducible: Always

Steps to Reproduce:
1. Make sure homepage is multi tab, like http://slashdot.org/|http://digg.com/
2. Go to suspected phishing site, such as Google's test site.
3. Click the Get me out of here! option.

Actual Results:  
It attempted to navigate to http://slashdot.org/|http://digg.com/ NOT to slashdot and digg in 2 separate tabs like they should.

Expected Results:  
Opened 2 tabs, one with Digg, and one with Slashdot.

Comment 1

12 years ago
This is likely to change. See bug 339032.
Depends on: 339032

Comment 2

12 years ago
I will confirm this *for now*, as I can reproduce this in the latest Bon Echo nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060810 BonEcho/2.0b1).  But yes, I'd love to see "get me out of here" do something more relevant.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Target Milestone: --- → Firefox 2

Updated

12 years ago
Flags: blocking-firefox2?
Target Milestone: Firefox 2 → Firefox 2 beta2

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+

Updated

12 years ago
Target Milestone: Firefox 2 beta2 → Firefox 2
So, window.home() breaks pretty badly if there's multiple homepages, we should a) decide what it should do and then b) make that happen

options are:
1) open first page
2) open all pages
3) fail brutally and shrug our shoulders

(3 really isn't an option)
Assignee: nobody → gavin.sharp
or 4) Open the home page if it's one page, or fail gently if it's not.

Looks to me like it's not calling window.home(), it's getting a URL in getMeOutOfHereUrl_() which defaults to about:blank, then tries to get the home page pref, and returns that (to loadURI()) if it can. The least painful non-scary thing would seem to me to .test() the pref value, and return about:blank if there's a pipe in it. In my multiple-home-page setups, having only the first page load would be more puzzling than comforting, and having all of them pop up would be more annoying than comforting.
(In reply to comment #3)
> So, window.home() breaks pretty badly if there's multiple homepages, we should
> a) decide what it should do and then b) make that happen

As Phil said, fixing window.home() to handle multiple home pages wouldn't fix this bug, since it's not used to load the home page. That problem is already filed as bug 343999. Given that Firefox is one of the only gecko apps to have "|" separated home pages, achieving adequate, non-hacky behavior is not trivial.

How about I fix bug 339032 instead? It should be fairly trivial, assuming beltzner's 339032 comment 14 describes the behavior we want.
Status: NEW → ASSIGNED
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Version: unspecified → 2.0 Branch
Whiteboard: [patch in 339032]
Fixed by the checkin for bug 339032.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Fixed on the branch by bug 339032.
Keywords: fixed1.8.1
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.