Mail can't be sent if 2 mails have attachments with same names and one draft ist closes (try to send 2 versions of a file simultaneously via MAPI)

RESOLVED DUPLICATE of bug 594243

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 594243
12 years ago
8 years ago

People

(Reporter: Michael Osipov, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Sending a file attachment from an app twice fails to send.
For my instace it's OpenOffice.org, take any version you like

Reproducible: Always

Steps to Reproduce:
1. Open a document in writer, calc, etc 
2. send this file as attachment, pick one you like
3. do this 2 in order to have 2 compose windows
4. now you have 2 compose windows having attachments w/ the same name
5. close one compose window
6. try to open the attachment in the compose window which remained open

doesn't work

7. now try to send, error msg

Actual Results:  
Mail isn't send because 2nd compose window overrode 1st attachment, both attachment point to the same file.
2nd compose is closed and first has a dead pointer

Expected Results:  
mail should be send correctly w/ attachmend
(Reporter)

Comment 1

12 years ago
TB version 1.5.0.4
Version: unspecified → 1.5
Reporter, could you please test with the latest supported 2.0.0.x / trunk nightlies and see if the issue still occurs?
Whiteboard: CLOSEME 2008-05-22
Sounds to be opposite situation to Bug 356808 / Bug 405717. (See also Bug 356919)
If attached file data in moz_mapi is not deleted after mail send, phenomenon becomes one in Bug 356808 / Bug 405717. 
If attached file data in moz_mapi is deleted after first mail send, phenomenon becomes this bug's one.

I did duplicate test of this bug in problem re-creation test for Bug 405717, and obtained same result as comment #0 with Tb 2 & trunk.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mail can't be sent if 2 mails have attachments with same names and one draft ist closes → Mail can't be sent if 2 mails have attachments with same names and one draft ist closes (try to send 2 versions of a file simultaneously via MAPI)
xref-ing above these four bugs.
Blocks: 356808, 356919, 405717
No longer blocks: 356808
Depends on: 356808
No longer blocks: 356919
No longer blocks: 405717
Whiteboard: CLOSEME 2008-05-22

Updated

10 years ago
Assignee: mscott → nobody
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594243
You need to log in before you can comment on or make changes to this bug.