www.mozilla.org missing SSL support

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Justin Fitzhugh)

Tracking

Details

(URL)

Attachments

(1 attachment)

problem loading https://www.mozilla.org/images/header_logo.gif

a side effect of this is when you go to report a bug on https://bugzilla.mozilla.org, you won't see the mozilla header image.
Created attachment 228611 [details]
screen shot of bugzilla without the header image, because https://www.mozilla.org is unreachable
Looks like it just needs to be changed to http://www.mozilla.org/images/header_logo.gif (http vs. https).
gavin, that would make the image show up but wouldn't that cause people to start getting the browser alert/warning about loading non-secure images in secure pages?
Yeah, I guess so. I guess the easiest solution would be to move the image to bugzilla.mozilla.org.

Comment 5

12 years ago
Looks like the same thing is happening on <http://hendrix.mozilla.org/> and <https://lists.mozilla.org/>. I assume it's the same cause.
*** Bug 344073 has been marked as a duplicate of this bug. ***
Cause: www.mozilla.org got moved to the new colo today.  Port 443 was apparently never opened on the firewall.
Assignee: nobody → server-ops
Severity: normal → critical
Component: www.mozilla.org → Server Operations
OS: Windows XP → All
QA Contact: www-mozilla-org → justin
Hardware: PC → All
Or, as it turns out, the load balancer wasn't told to handle SSL for the site.
Summary: problem loading https://www.mozilla.org/images/header_logo.gif → www.mozilla.org missing SSL support
Justin's working on this as I type
Assignee: server-ops → justin
(Assignee)

Comment 10

12 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

12 years ago
SSL offload prep'd but requires DNS updates for www.mozilla.org and mozilla.org to 63.245.209.11.  

The fix working right now was temporary while I added the correct SSL certificate chains in place.  

In any event, .11 is answer for http and https so DNS can be changed whenever.  I would, however, like someone else to check it to be sure. 
> I would, however, like someone else to check it to be sure. 

matthew, I'm no longer seeing the bug that I reported with https://bugzilla.mozilla.org and https://www.mozilla.org/images/header_logo.gif now loads fine.
DNS for www.mozilla.org has been changed to point at .11
(Assignee)

Comment 14

12 years ago
This actually was resolved via a https pass-thru, now being offloaded to the netscalers.  Anyways, it's done.  Let us know if you see any more issues.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.