Functions prototyping partially broken

RESOLVED DUPLICATE of bug 343966

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 343966
12 years ago
12 years ago

People

(Reporter: dao, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060709 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060709 Minefield/3.0a1

see testcase

Reproducible: Always

Steps to Reproduce:
Function.prototype.foo = true;
function y(){};
alert (y.foo);

Actual Results:  
undefined

Expected Results:  
true

Regressed within the last few days (worked last Friday, I think). Not happening on the 1.8 branch.
(Reporter)

Comment 1

12 years ago
Created attachment 228623 [details]
testcase
Keywords: regression
Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?date=explicit&mindate=2006-07-07+02%3A00&maxdate=2006-07-08+05%3A00

Looks like a regression from bug 343417.
Blocks: 343417
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Yeah, I'm going to look into this tomorrow.

*** This bug has been marked as a duplicate of 343966 ***
No longer blocks: 343417
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

12 years ago
Checking in regress-344052.js;
/cvsroot/mozilla/js/tests/js1_5/Function/regress-344052.js,v  <--  regress-344052.js
initial revision: 1.1

I am surprised we didn't have test coverage for this already.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.