autoscroll image positioned incorrectly when CSS is disabled

VERIFIED DUPLICATE of bug 258841

Status

()

VERIFIED DUPLICATE of bug 258841
13 years ago
12 years ago

People

(Reporter: ldrhcp, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The autoscroll image appears behind the cursor when the middle mouse button is pressed on an HTML document. This image is appended to the root element (HTML), and is placed behind the cursor using CSS. When CSS is disabled, the image cannot be positioned and appears at the bottom of the document.

Reproducible: Always

Steps to Reproduce:
1. Open any document.
2. Disable CSS. (In Firefox: View -> Page Style -> No Style)
3. Middle click.
Actual Results:  
The autoscroll image appears at the end of the document.

Expected Results:  
The autoscroll image should be positioned behind the cursor.
Much as we might like to find some way to blame layout, it's Firefox that's shoving chrome into the content DOM, and counting on no CSS conflicts or CSS being disabled.

*** This bug has been marked as a duplicate of 258841 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: Layout → General
Product: Core → Firefox
QA Contact: layout → general
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.