Thunderbird crashes after selecting mails in the main mail window [@ JS_strtod]

RESOLVED DUPLICATE of bug 334263

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 334263
12 years ago
7 years ago

People

(Reporter: tomasio, Assigned: Scott MacGregor)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Thunderbird Version 1.5.0.4 (20060516)

Crashes after selecting mails in the 3-folder-pane mail window. Happens when I click mails with the mouse pointer but also if I try to read the next message via keyboard. Behaviour still appears after going through steps explained in http://kb.mozillazine.org/Standard_diagnostic_%28Thunderbird%29. 

Deleting the "XUL.mfl"-file in "C:\Dokuments and Settings\User Name\Local Settings\Application Data\Thunderbird\Profiles\yourprofilename seems to reduce the amount of crashes, but only for a short period of time. 

As this is very annoying and scares users away from using TB at all I would like to have this fixed ASAP.

Reproducible: Sometimes

Steps to Reproduce:
1. Start TB
2. Click one of the mails in the list view
3. Crashes after reading a few mails

Actual Results:  
Crashes every time

Expected Results:  
should show the contents of selected mails

Uninstalling any themes but default theme did not change the behaviour.

Comment 1

12 years ago
*** Bug 344104 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
Please install or enable Talkback and get a Talkback ID for the crash. http://kb.mozillazine.org/Talkback
(Reporter)

Comment 3

12 years ago
Created attachment 229041 [details]
Textfile with the detailed talkback description of enclosed Talkback ID

TB20892447H This is the Talkback ID of the last crash. If you want do, I can put the whole list here.

Comment 4

12 years ago
Thanks, tomasio. Turns out this is a duplicate of another bug.

Incident ID: 20892447
Stack Signature	JS_strtod 7a6643dd
Product ID	Thunderbird15
Build ID	2006051612
Trigger Time	2006-07-12 22:56:40.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	js3250.dll + (00010405)
URL visited	
User Comments	
Since Last Crash	1092 sec
Total Uptime	367328 sec
Trigger Reason	Invalid operation
Source File, Line No.	c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsdtoa.c, line 1243
Stack Trace 	
JS_strtod  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsdtoa.c, line 1243]
js_strtod  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsnum.c, line 936]
js_ValueToNumber  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsnum.c, line 744]
num_isNaN  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsnum.c, line 73]
js_Invoke  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1188]
js_Interpret  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 3584]
js_Invoke  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c, line 1208]
nsXPCWrappedJSClass::CallMethod  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1373]
nsXPCWrappedJS::CallMethod  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 462]
SharedStub  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsMsgStatusFeedback::OnStateChange  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/mailnews/base/src/nsMsgStatusFeedback.cpp, line 176]
nsDocLoader::FireOnStateChange  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 1210]
nsDocLoader::doStopDocumentLoad  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 844]
nsDocLoader::OnStopRequest  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/uriloader/base/nsDocLoader.cpp, line 665]
nsLoadGroup::RemoveRequest  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsLoadGroup.cpp, line 732]
PresShell::RemoveDummyLayoutRequest  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 7125]
DummyLayoutRequestEvent::HandleEvent  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 7025]
0x778b0c24
nsHTMLEditor::RelativeFontChangeHelper  [c:/builds/tinderbox/Tb-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/editor/libeditor/html/nsHTMLEditorStyle.cpp, line 1726]
0x029a0292

*** This bug has been marked as a duplicate of 334263 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: Thunderbird crashes after selecting mails in the main mail window → Thunderbird crashes after selecting mails in the main mail window [@ JS_strtod]
Crash Signature: [@ JS_strtod]
You need to log in before you can comment on or make changes to this bug.