Proxy: "No proxy for" setting doesn't appear to work

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: Thomas Yeo, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; NT4.0; en-US) Mozilla/m13
BuildID:    2000022820

I hope you can test this.

I am running the browser in a VPN (Virtual Private Network). We have an intranet
that need to bypass the proxy settings (which is the corporate firewall). The
ftp and http proxy setting is set to an address (let's say xxx.yyy.net port 80).
The No proxy for has been set to the intranet I'm trying to access. This is
entered in the form of aaa.bbb.net .

The usual thing that initially happens when we go to the intranet website is
that a dialogue box pops up prompting for the username and password (with SSL on).

In this case the browser does not respond. It just loads the document and
completes it. It doesn't appear to do anything. The previous page still remains.
Nothing gets refreshed.


Reproducible: Always
Steps to Reproduce:
1.Set the proxy setting to the corporate firewall
2.Set the no proxy setting to the web site desired. (aaa.bbb.net)
3.go to the website with no proxy set.	(http://aaa.bbb.net)


Actual Results:  Nothing happens

Expected Results:  Pop up a dialogue box prompting for username and password.
The page should be in SSL mode.
thomas_yeo@bigfoot.com - are you still seeing this problem with recent builds of 
Mozilla?

Gerv
Reporter said:

"No. It is cool. I've actually started looking at Netscape 6 instead. Looks
like the code has been tidied up. Must admit that I was really dumb
initially when it comes to installation, and checking to see what was and
wasn't working. Suspect that some of it was my error.

Hey Preview version, for what it is, is stonkingly fast (if there is such a
word) compared to Netscape 4+ and about on par with IE5.

One surprising thing I've recently found was the speed of Netscape 4.7 on
Linux compared to Netscape and IE on Windows NT. It was really night and day
stuff. Same internet pipe, just different OS. Is that the perfect platform
for browsing or what!

Keep up the great work."

Marking WORKSFORME.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
qa to me
cleaned up summary
VERIFIED:
Another happy customer. Reported long enough ago this didn't work or the docs 
were wrong.

Bug 49858 has correct syntax.
Status: RESOLVED → VERIFIED
QA Contact: tever → benc
Summary: No proxy setting doesn't appear to work → Proxy: "No proxy for" setting doesn't appear to work

Comment 4

17 years ago
should have made previous comments as "benc@netscape.com"...
You need to log in before you can comment on or make changes to this bug.