popup blocker - preference for small notification icon in status bar instead of popup notification bar (a la Firefox)

VERIFIED DUPLICATE of bug 333531

Status

Camino Graveyard
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 333531
12 years ago
12 years ago

People

(Reporter: Chris Linstid, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Camino/1.0+

At the moment in Camino when a popup is blocked, we get the popup blocker notification bar below the tab bar.  While I think this makes perfect sense as the default preference, I would love to see a preference that mirrors the functionality in Firefox where you can specify that the only notification you get is a small icon in the status bar at the bottom of the window that has a contextual menu for Unblock and Configure.  I'm not sure whether it was a design choice for it to be this way or what, but I would be very happy to see this happen.

I did the best I could to search for an existing bug like this, but I couldn't find one, so here it is.  I will be happy to clarify what I mean if needed.

Thanks.


Reproducible: Always

Steps to Reproduce:
1. Go to a website that has unsolicited popups and that is currently blocked.

Actual Results:  
1.  Popup blocker notification bar appears below the tab bar.

Expected Results:  
Shown an option for not displaying the popup blocker notification bar for future blocked popups.

Comment 1

12 years ago
/me weeps softly to himself

*** This bug has been marked as a duplicate of 333531 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
Don't fret it.  I wasn't crying because it was a dupe, but rather because it's necessary in the first place (notice who filed the bug I just duped it to) ;)
(Reporter)

Comment 3

12 years ago
I thought I had done a pretty thorough search for an existing bug, but I searched for "popup" and not "pop up"... so it wasn't quite as thorough as I should have been. 

I have since voted for the original, so hopefully that will help.

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.