<SCRIPT> contents are not properly parsed

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: ulf.axelsson, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
(Version is M14!)

- Open one of the newsitems on this page

- Look near the bottom of the page to the right of the links to
  other newsitems.

Part of a <script> </script> tag are visible.

Apparently the parser terminates the <script> tag with a </script> tag
that is part of the text being written to the document within the script.

It is rather odd JS-code but I think the parser should be able to handle
it.
It's actually the correct behavior according to the HTML spec.  The first
occurrence of </ ends a script element, and it should thus be escaped within JS
strings as <\/ .

There are other bugs on this, most of which have been marked wontfix, but one of
which was marked fixed (partially).

Comment 2

19 years ago
This seems to have been fixed along with the other </script> bug; at least
there's no stray script code showing up on the page anymore on build
2000.04.16.06.  Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.