Closed Bug 344172 Opened 13 years ago Closed 13 years ago

Spellchecker doesn't display suggestion list for misspelled words and doesn't underline them if Russian, Ukrainian or Bulgarian Spell dictionary is installed

Categories

(Core :: Spelling checker, defect, major)

1.8 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla1.8.1beta2

People

(Reporter: unghost, Assigned: roc)

References

Details

(Keywords: fixed1.8.1, regression, verified1.8.1.3)

Attachments

(5 files)

1. Install latest Firefox Branch Build 
2. Install Russian Spell Checker from
http://downloads.mozdev.org/dictionaries/spell-ru.xpi (you need to unpack it and put "ru.aff" and "ru.dic" files in "C:\Program Files\Mozilla Firefox\dictionaries" )
3. Select Russian dictionary from context menu.
4. Write misspelled word in Russian in some web form.

Actual results:
Firefox doesn't display suggestion list for misspelled word and doesn't underline it with red line.

Expected results:
Firefox should display suggestion list for misspelled word and underline it with red line.

Additional information:
I've made some tests and found regression window.

This bug doesn't exist in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060705 BonEcho/2.0a3 ID:2006070504
This bug exist in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060706 BonEcho/2.0a3 ID:2006070603
Looking at regression window it's regression from Bug 343532 or Bug 339066

I'll attach some screenshots.
Attached image Working spell check
Spell check in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060705 BonEcho/2.0a3 ID:2006070504
Attached image Broken spell check
Spell check in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060706 BonEcho/2.0a3 ID:2006070603
I've made few more tests, looks like Ukrainian and Bulgarian spellchecker are broken too (these are languages with cyrillic alphabet).
Setting severity to major, adding "regression" keyword and asking for blocking 1.8.1.
Will attach 2 more screenshots.
Severity: normal → major
Flags: blocking1.8.1?
Keywords: regression
Boris, you've helped a lot with Bug 307052. Symptoms of this bug is similar, and I greatly appreciate if you can take a look at it.
Summary: Spellchecker doesn't display suggestion list for misspelled words and doesn't underline them if Russian Spell dictionary is installed → Spellchecker doesn't display suggestion list for misspelled words and doesn't underline them if Russian, Ukrainian or Bulgarian Spell dictionary is installed
Flags: blocking1.8.1? → blocking1.8.1+
Target Milestone: --- → mozilla1.8.1beta2
Depends on: 339066
The bugs listed in comment 0 were both fixed by commits Roc made, so he might have some idea where to go with this (I see he's already CCed on the bug).
It's probably a regression from my changes. Please don't bother Boris with it.
Attached patch fixSplinter Review
Fairly obvious bug in retrospect. Comparing just the bottom 8 bits to see if it's a digit isn't a good idea... we need a better Unicode-aware test here though.
Assignee: mscott → roc
Status: NEW → ASSIGNED
Attachment #229985 - Flags: superreview?
Attachment #229985 - Flags: review?
Attachment #229985 - Flags: superreview?(mscott)
Attachment #229985 - Flags: superreview?
Attachment #229985 - Flags: review?(mscott)
Attachment #229985 - Flags: review?
Comment on attachment 229985 [details] [diff] [review]
fix

thanks roc!
Attachment #229985 - Flags: superreview?(mscott)
Attachment #229985 - Flags: superreview+
Attachment #229985 - Flags: review?(mscott)
Attachment #229985 - Flags: review+
Is this patch ready to be checked in to trunk? It has needed r/sr.
Whiteboard: [needs-checkin]
Whiteboard: [needs-checkin] → [checkin needed]
Checking in mozInlineSpellWordUtil.cpp;
/cvsroot/mozilla/extensions/spellcheck/src/mozInlineSpellWordUtil.cpp,v  <--  mo
zInlineSpellWordUtil.cpp
new revision: 1.6; previous revision: 1.5
done

Checked into trunk.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Verified fixed with "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060724 Minefield/3.0a1" build.
Status: RESOLVED → VERIFIED
Ready to ask for branch approval?
Comment on attachment 229985 [details] [diff] [review]
fix

a=dbaron on behalf of drivers.  Please check in to MOZILLA_1_8_BRANCH and mark fixed1.8.1 once you have done so.
Attachment #229985 - Flags: approval1.8.1? → approval1.8.1+
I won't be able to check this in for a few days...
Whiteboard: [checkin needed]
Checking in mozInlineSpellWordUtil.cpp;
/cvsroot/mozilla/extensions/spellcheck/src/mozInlineSpellWordUtil.cpp,v  <--  mo
zInlineSpellWordUtil.cpp
new revision: 1.4.2.3; previous revision: 1.4.2.2
done

Checked into 1.8.1 branch.
Keywords: fixed1.8.1
Whiteboard: [checkin needed]
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 and the STR from comment #0 - spellcheck is working now for the 3 languages (Russian, Ukraine, Bulgarian) 
Keywords: verified1.8.1.3
You need to log in before you can comment on or make changes to this bug.