[BLOCK] AppRunner/Linux: Optimized build renders blank window

VERIFIED WORKSFORME

Status

Core Graveyard
Tracking
P1
normal
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Chris McAfee, Assigned: Chris McAfee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
The app sets up, draws a grey window, and then goes
into an endless loop:

  gettimeofday({920626579, 629529}, NULL) = 0
  ioctl(7, FIONREAD, [0])                 = 0
  SYS_168(0x80ed418, 0x3, 0, 0x40823494, 0) = 0
  gettimeofday({920626579, 630010}, NULL) = 0

yank --enable-debug out of configure to get an opt. build.
(Assignee)

Comment 1

19 years ago
*** Bug 3443 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

19 years ago
Passing an URL argument to apprunner works, something's up
with CSS/XUL?
(Assignee)

Comment 3

19 years ago
waterson & I debugged this over irc, apprunner/opt isn't loading
xul files properly.  RDF?  Adding waterson to CC list.

Comment 4

19 years ago
So after a bit of debugging-via-IRC, we were able to determine that...

1. HTML can load, XUL can't.
2. It seems like librdf.so is being loaded, because with
NSPR_LOG_MODULES=nsRepository:5
(and adding #define FORCE_PR_LOG to nsRepository.cpp), we saw CIDs from
librdf.so being
constructed.

Anyway, I'm stumped.

Updated

19 years ago
Target Milestone: M3

Updated

19 years ago
Summary: AppRunner/Linux: Optimized build renders blank window → [BLOCK] AppRunner/Linux: Optimized build renders blank window

Comment 6

19 years ago
This is a milestone blocker.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

19 years ago
Yeah, this just started working for me.
marking worksforme.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Marking Verified/WorksForMe.

Comment 9

19 years ago
Moving from Apprunner to Other component temporarily whilst don and I set proper
component.  Apprunner component will be retired/deleted shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.