Add Preference to Open New Tabs next to Current Tab

RESOLVED DUPLICATE of bug 262459

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 262459
11 years ago
11 years ago

People

(Reporter: ronin.achilles, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060710 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060710 BonEcho/2.0b1

As of now by default, all new tabs are opened at the end of the Tab Bar. This IMO has some usability issues. For example: Lets say I have 30 Tabs Open. My 2nd Tab is a Google Search Result Page. Now I open 5 links from this result page (as new tabs). These links open as Tab Nos. 31 to 35. I have to scroll all the way to 31 to access these tabs. Now if I have to open another 5 search results, I have to come back to Tab No. 2 and open the next 5 search results, and then again scroll to Tab No. 36-40 to access the new tabs.

This is just one scenario where things become increasingly inconvenient as the number of tabs increase. Various such scenarios can be created.

Solution: A Tab Preference should be provided where a user can select to open a new tab next to the currently focused tab.



Reproducible: Always
The Tab Control extension has this functionality, also an UI for chancing the tab width. It is an extension with only a few functions and AFAIK it works well with the recent tabbed browser changes.
I'm pretty sure that this bug is a duplicate.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> The Tab Control extension has this functionality, also an UI for chancing the
> tab width. It is an extension with only a few functions and AFAIK it works well
> with the recent tabbed browser changes.
> I'm pretty sure that this bug is a duplicate.
> 

There are quite a few extensions which have this functionality including Tab Mix Plus which I use. But I guess this is a very basic usability issue and hence IMO this preference should be part of the default browser.

Comment 3

11 years ago

*** This bug has been marked as a duplicate of 262459 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.