Closed Bug 344216 Opened 14 years ago Closed 9 years ago

"ASSERTION: Adding child where we already have a child? This will likely misbehave" with script-added <xul:iframe> on reload

Categories

(Core :: Document Navigation, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

437 bytes, application/vnd.mozilla.xul+xml
Details
Loading the testcase causes "ASSERTION: Adding child where we already have a child?  This will likely misbehave".

Bug 314457 and bug 307241 are also about this assertion, but they have different testcases and I can't reproduce the assertion with those testcases.
Attached file xul testcase
Blocks: 344486
Still happens on trunk with this testcase.
This assertion also shows up on every keypress on http://htmledit.squarefree.com/, which is pretty annoying.
That seems odd, and worth a separate bug.  All we need then is someone to own this code and debug these assertions..

This bug is more or less bug 314457 as far as I can tell.
Depends on: 314457
Ok, I filed bug 396836 on that.
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
The testcase gives the identical stack as the one on bug 462076 which already has a WIP patch.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462076
The same stack does NOT mean it's a duplicate.  Please mark dependent if you think the other patch might fix this bug.  This eager dup-marking is a great way to miss fixing issues.
Status: RESOLVED → REOPENED
Depends on: 462076
Resolution: DUPLICATE → ---
Blocks: 535466
This should be fixed by bug 462076 and the disable-xul-in-web-content.
Status: REOPENED → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.