Don't change mouse cursor when moving tabs to another position

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: Gero Mudersbach, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.3 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.9a1) Gecko/20060711 Minefield/3.0a1

When moving a tab to another position there are three visual changes: the mouse cursor changes to a cross, an icon appears next to the mouse cursor and there is a little arrow between the tabs (showing where the tab would be placed when user releases the mouse-button). All these changes are confusing when we are switching between the tabs and don't want to change order. Also this behaviour isn't concurrent with all OSs, it's a gtk feature (we don't see this on Win32). See bug #307184 for more information.

Reproducible: Always

Steps to Reproduce:
1. Open up three or more tabs
2. Switch between tabs fast
3. Notice the dragging icon and the cursor change

Actual Results:  
Visual changes that confuse the user

Expected Results:  
One visual change indicating where the tab should go when dragging occurs, no visual change when switching between the tabs

See bug #307184

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

10 years ago
so you don't want the mouse to change when dragging tabs?

(changing to enhancement)
Severity: normal → enhancement
(Reporter)

Comment 2

10 years ago
Yes, I was referring to bug #307184#c19

I couldn't take a look at the FF3 on Win32 though. I think the behaviour should be consistent on all platforms. Also, I think the mouse cursor itself should not change while dragging something, because in core os applications it does not change when dragging but places an icon of the object to be dragged next to the normal "pointer". Also see:
http://library.gnome.org/devel/hig-book/stable/input-mouse.html.en#drag-drop-pointers
http://library.gnome.org/devel/hig-book/stable/input-mouse.html.en#drag-drop
http://wiki.openusability.org/guidelines/index.php/Design_and_Layout:Interaction:Drag_and_Drop
http://msdn.microsoft.com/en-us/library/bb545459.aspx
http://techpubs.sgi.com/library/tpl/cgi-bin/getdoc.cgi/0650/bks/SGI_Developer/books/UI_Glines/sgi_html/ch07.html#id77130

All these guidelines suggest using the same mouse pointer while dragging and display usefull information to the lower right corner of the pointer (like "dragging forbidden", "copy", "move", "document icon").

Comment 3

5 years ago
The mouse cursor doesn't change in Firefox 25.  It remains an arrow, and shows a small thumbnail of the page in question.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.