Uncaught Exception... "Invalid pointer arg 1 [nsIDOMHTMLDocument.getElementById]"

RESOLVED DUPLICATE of bug 344830

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 344830
11 years ago
11 years ago

People

(Reporter: Quel Qun, Unassigned)

Tracking

({regression, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060710 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060710 BonEcho/2.0b1

I've attached 2 files test.html and dynamic.svg.
Go to test.html in firefox 1.5.* and you'll get a test passed message.
In Firefox 2.0 beta 1 you'll just get an error in the log:

Error: uncaught exception: [Exception... "Invalid pointer arg 1 [nsIDOMHTMLDocument.getElementById]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///var/tmp/test.html :: test :: line 6"  data: no]


Reproducible: Always

Steps to Reproduce:
<html>
<head>
<script language="JavaScript">
  function test()
  {
    var embd = document.getElementById("svgEmbd");
    alert('test passed');
  }
</script>

</head>

<body onload="javascript:test();">
   <embed id="svgEmbd" width="15" height="15" src="dynamic.svg" type="image/svg+xml"/>
</body>

</html>

Actual Results:  
Works with ffox 1.5, breaks with Bon Echo 2.0b1


I could not find it, but I apologize in advance if this has already been reported.
(Reporter)

Comment 1

11 years ago
Created attachment 229139 [details]
test page that loads fine in 1.5
(Reporter)

Comment 2

11 years ago
Created attachment 229141 [details]
embedded svg

Comment 3

11 years ago
This appears to be fixed in bug 344830.

Comment 4

11 years ago
Yeah, this appears to be a duplicate, the testcase is WFM with the latest bon echo branch build.

*** This bug has been marked as a duplicate of 344830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: regression, testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.