Default Tags are not being set as the correct imap keywords on the imap server

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Bruce Z. Lysik, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: version 2 alpha 1 (20060711)

When I select an a default tag such as 'Important' or 'Later' and apply it to a message, the imap keyword which gets set in the imap server is $labelx (where x is a number).

For example, I just set an email as 'Important', and then I check the imap keywords set in that message folder.  (By viewing the ':list' file in courier-imap):

 > more :list
NonJunk
$label1

1152649351.68367_1.raisewise.corp.yahoo.com:0
1152649417.68423_1.raisewise.corp.yahoo.com:0
1152649417.68426_1.raisewise.corp.yahoo.com:0
1152649484.68442_1.raisewise.corp.yahoo.com:0
1152649484.68445_1.raisewise.corp.yahoo.com:1 0

So you can see the '$label1' is being set instead of 'Important'

Reproducible: Always

Steps to Reproduce:
1. Set a default tag to an email.

Actual Results:  
View the imap keywords file on the imap server and see $labelx instead of the actual tag.


Expected Results:  
I expect to see Important or Later.

courier-imap-4.0.6
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0

Comment 1

12 years ago
actually, that's the expected, correct behaviour. That keeps backward compatibility with old labels.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
Whoops.  Nevermind then.  Thanks. :)

Comment 3

12 years ago
If you really want the keywords on the server to match the tags, and don't care about backwards compatibility, you can delete the default tags and then add them back yourself - then we'll use the matching keys. You might want to shut down after deleting the tags because of https://bugzilla.mozilla.org/show_bug.cgi?id=345999
(Reporter)

Comment 4

12 years ago
I don't need the server keywords to match the tags.  This was just part of my investigating why I can't search by tag.  (I though this was the culprit.)
You need to log in before you can comment on or make changes to this bug.