firefox extensions say "[extension] will be installed when firefox is restarted" but don't install.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: findingtuesday, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

4.80 KB, application/extensions.ini
Details
86.65 KB, application/extensions.rdf
Details
7.79 KB, application/extensions.cache
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

i installed new extensions and also ran the updates for existing extensions.  all the extensions installed properly and now appear in my extensions list, with the usual "[extension] will be installed when firefox is restarted."  restarted firefox a number of times but they do not update and still say firefox needs to be restarted.  i uninstalled and reinstalled firefox; uninstalled, restarted my computer, and reinstalled, and i still don't have the extensions working and it continues to say i need to restart.  
an extension i accidentally clicked on to uninstall has also not done so despite all the reinstallations, so i don't believe reinstalling all of them will work anyway... plus, i don't want to have to uninstall and reinstall all these extensions.

hope this has given you enough information.  thanks in advance for your help.

Reproducible: Always

Steps to Reproduce:
1. restarted firefox
2. reinstalled firefox
3. tried to uninstall extension

Actual Results:  
continue to get the same message beneath all the extensions listings.

Expected Results:  
installed.

Updated

12 years ago
Component: Listings → Extension/Theme Manager
Product: Update → Firefox
QA Contact: listings → extension.manager
Version: unspecified → 1.5.0.x Branch
Can you zip up your profile's extensions directory along with the extensions.rdf, extensions.cache, and extensions.ini files that are located inside your profile's directory and email the zip file to me?
http://www.mozilla.org/support/firefox/profile

Comment 2

12 years ago
I assume you know about ctrl+alt+del -> end task on firefox.exe processes if something like this is happening?
(Reporter)

Comment 3

12 years ago
i tried ctrl+alt+del, i tried going in through the task manager to end it, i've tried uninstalling and reinstalling.  none of that has helped, firefox and the computer have been turned off, restarted, etc, yet it still says itneeds to be restarted for the extensions to install.
Reporter, please follow the instructions in comment #1 so I can find what the cause of this is.
(Reporter)

Comment 5

12 years ago
Created attachment 230378 [details]
one of the files
(Reporter)

Comment 6

12 years ago
Created attachment 230379 [details]
extensions.rdf
(Reporter)

Comment 7

12 years ago
Created attachment 230380 [details]
extensions.cache
(Reporter)

Comment 8

12 years ago
Created attachment 230381 [details]
extensions.cache
(Reporter)

Updated

12 years ago
Attachment #230381 - Attachment is obsolete: true
(Reporter)

Comment 9

12 years ago
(In reply to comment #4)
> Reporter, please follow the instructions in comment #1 so I can find what the
> cause of this is.
> 

sorry, i've been trying.  did you get my email regarding trying to send it and it saying the file was protected [or something like that?].  i just tried to put it as an attachment to the bug, but it froze my computer up.  i'm trying again, i at least have .ini, .cache, and .rdf.  it's just the extension directory itself that's proving too big to attach. 
success!  i uploaded it to yousendit
http://www.yousendit.com/transfer.php?action=download&ufid=AA428CC374AFCF02
hope that works for you.
Sent email re: alternative method to send me the files
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> Sent email re: alternative method to send me the files
> 

did the link for yousendit.com not work?  my connection keeps getting reset when i try to send the email to you.
I never received a file from yousendit.com.
(Reporter)

Comment 13

12 years ago
i left it as a link in a reply to your comment.
http://www.yousendit.com/transfer.php?action=download&ufid=AA428CC374AFCF02
(In reply to comment #13)
> i left it as a link in a reply to your comment.
> http://www.yousendit.com/transfer.php?action=download&ufid=AA428CC374AFCF02
Sorry... I'm so used to getting them via email that I didn't notice. :(

I have the files now and since you are on l.5 I'd like you to manually remove the following from within your extensions directory:
blue
HD-carbonfiber
Longknot
RE-EVOLUTION-B
ScribbliesPlain
staged-xpis
stopreload
tabbin
tabx
temp
contents.rdf
Extensions.rdf
icon.png
installed-extensions.txt
preview.png

The files you will be removing are either no longer used by 1.5 or shouldn't be there at all. The directories are either leftover from 1.0 when the required naming convention was not enforced or they are staging directories for installations.

I loaded this with a 2.0 build and everything loaded fine. I'm now going to check how it behaves with 1.5.0.5.
I just loaded your extensions with 1.5.0.5 and it didn't exhibit this problem. Could you try 1.5.0.5 and see if the problem is still present with it?
btw: when I tested it I didn't remove the directories and files listed in comment #14 and it still wfm. It would be a good thing for you to remove those files anyways.
I also tried to duplicate with 1.5.0.4 without success. If after removing the directories and files listed in comment #14 it still doesn't work you can probably get it to work again by deleting the extensions.rdf in your profile directory and restarting. It will be automatically regenerated.
(Reporter)

Comment 18

12 years ago
deleting those worked!  thanks so much for sticking with me on fixing this, i really appreciate it 
:]
jessie-mae
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.