keystrokes go to wrong window

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: ben, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.14masq i686; Nav)
BuildID:    2000030316

I am not sure I have the pattern figured out correctly yet but sometimes when
you do an "open link in new window" and it creates a new window. The keystrokes
go to the window from which you created the new browser window not the window
you are over.

I think that the pattern is when the mouse is in the new window but over an
obscured part of the older window. I am not sure about this. I haven't seen a
case where that wasn't the case though.

It also might be in the cases where I have never moved the mouse out of the new
window since it appeared.

Reproducible: Sometimes
Steps to Reproduce:
1.Open a page with at least one link on it.
2.Do a right click and open the link in a new window
3.Hit page down or alt-W

Actual Results:  The old window scrolls

Expected Results:  The new window scrolls

Been trying to pin this one down to something that could be reliably reproduced
for some time but I haven't been able to. I figured this might help even if it
takes you some time to reproduce it.
(Assignee)

Comment 1

19 years ago
asadotzler@netscape.net (Asa Dotzler) taking ownership of Browser General bugs. 
 New QA Contact is jelwell@singleclick.com (Joseph Elwell).  Sorry for the spam.
Assignee: cbegle → asadotzler
QA Contact: asadotzler → jelwell

Comment 2

19 years ago
reproter - what build are you on? you wrote this report on ns4.7
(Assignee)

Comment 3

19 years ago
builds from 3/3 are quite old.  Please download a current build and re-open if 
you still see this behavior.  Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 4

19 years ago
marking verified. this should really be worksforme, tested on linux build
2000042113.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Haven't seen this bug in M15. You can close it if you like.
(Assignee)

Comment 6

19 years ago
Closed is reserved for after mozilla "ships" so we'll just leave it at 
verified.  Thanks for testing Mozilla and reporting bugs.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.