All users were logged out of Bugzilla on October 13th, 2018

Signature separator is automatically set if there is none in the signature file; Need pref to choose, whether the separator is set automatically

RESOLVED DUPLICATE of bug 58406

Status

RESOLVED DUPLICATE of bug 58406
12 years ago
10 years ago

People

(Reporter: jiha.bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060708 Mnenhy/0.7.4.10001 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060708 SeaMonkey/1.5a; Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060619 Thunderbird/1.5.0.4; TB 1.5.0.4 under Windows XP 

You might append some additional Information (e.g. contact data as phone no, company etc.) to all of your emails, that should not be treated as a standard signature. A standard signature is cut in replies. 
In mail conversations, especially in business connections, these information should be kept. Currently there is no way to do so.

Reproducible: Always

Steps to Reproduce:
1. create a text file e.g. with your contact data; the file must not contain a "-- "
2. use the file as signature file
3. compose new message

Actual Results:  
The content of the signature file is automatically pasted into the compose window. There is automatically set a empty line, a line with "-- " (of course without the "") in front of the text.

Expected Results:  
There should be a way to choose, whether the empty line and the --  are set or not.

Suggestion: There should be a pref to trigger that for every signature for every identity.

Comment 1

12 years ago
(In reply to comment #0)
> In mail conversations, especially in business connections, these information
> should be kept.

If I'm replying to your message, what reason is there for you to see your own sig?  That is the logic behind cutting the sigs.


> Currently there is no way to do so.

I think this is a dupe of bug 58406.

One other thing that 'business' people like to do with email is put their own reply on top, followed by their own sig, followed by the quoted text of the previous message.  If you set up sig placement to behave this way, the sig separator is not included with the sig -- not so much for the reason given in this bug, but to prevent all the following quoted text from being cut in the next reply.

Also, note that if the message you reply to is HTML rather than plain, the sig is not cut.  There's a bug open somewhere to change that, but I can't find it 
at the moment.

See also bug 201581, which addresses the same problem when the received mail 
has a sig separator placed which causes the subsequent body to be cut.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > In mail conversations, especially in business connections, these 
> > information should be kept.
> 
> If I'm replying to your message, what reason is there for you to see your own
> sig?  That is the logic behind cutting the sigs.

Well, you have to think about email conversations that go step-by-step through many people's hands: A problem is discussed, cannot be solved, so it is send to the next "specialist". The specialist is sending it to another specialist or maybe to his boss and so on... And all these new people should get _all_ information. Also the information mentioned in the sigs (in my example the "business contacts"). So you can easily make a phone call or whatever.

> > Currently there is no way to do so.
> 
> I think this is a dupe of bug 58406.

I think you're right. Most of the people there have the same opinion as mine. They see the problem especially for emails.

> One other thing that 'business' people like to do with email is put their own
> reply on top, followed by their own sig, followed by the quoted text of the
> previous message.  If you set up sig placement to behave this way, the sig
> separator is not included with the sig -- not so much for the reason given in
> this bug, but to prevent all the following quoted text from being cut in the
> next reply.

That's right. Another important reason. That's bug 201581 as you mentioned.

> Also, note that if the message you reply to is HTML rather than plain, the 
> sig is not cut.

Thanks for info. Didn't know that.
But in my opinion HTML-mail is evil. ;-) 

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 58406 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.