RFE: Add enhanced notification that new mail has arrived

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: Art Parmet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

SM offers two methods to identify folders with unread messages - One is 
to click on the "unread" tab in the mail and newsgroups account pane 
which shows the unread messages count in a separate column next to each 
folder or sub-folder. The other is to leave this option unchecked and 
the unread messages count appears in parenthesis next to the folder 
(e.g.: Inbox (1)).

The limitation of these is that the account folder must be open to see 
this status. The top level folder for the account is always in bold and 
does not give any indication of unread mail status in the 
folders/sub-folders below it. If you have a number of mail accounts and 
sub-folders deployed, this results in a long list of folders and 
sub-folders and periodic manual scrolling to see if there are unread 
messages.

Alternatives to this would be:

1) Flag the existence of unread messages at the top level mail/newsgroup 
folder level for each account

2) Provide a toolbar global indicator (flashing icon, text or other) 
that some folder has unread messages. This would allow the account 
folder to remain closed and thus shorten the list.

3) Allow an option for the Mail and Newsgroup / Notifications sound to 
periodically be played if there are unread messages. This is the least 
desirable as it may become annoying unless a quick method to clear the 
indicator (e.g.: toolbar button) is provided.

Reproducible: Always

Comment 1

12 years ago
There is a substantial difference between "new" messages and "unread" ones.  When you summarize this bug as being about "notification that new mail has arrived" you're talking about the first, so whereever you write "unread" here, I'm assuming you actually mean "new."  That said:


(In reply to comment #0)
> The top level folder for the account is always in bold and 
> does not give any indication of unread mail status in the 
> folders/sub-folders below it. 

Not entirely true.  An account which has just received new mail gets a "new" flag, which normally appears as an enhancement on the icon -- a little green dot (or in a theme I used to use, a yellow halo).  But this indicator disappears as soon as any folder of the account is visited or (if already 
in the Inbox) as soon as a new message is read.  (And see bug 116181 and 
bug 210148, among others, for problems with this scheme.)

To clarify (because this isn't obvious): A folder containing a new message will show a "new" indicator, but an account containing a new message only shows a "new" indicator until a user action clears it.

Also note:  The "new" flag on a message is cleared when the message is marked read, but also when you switch from the folder containing the message to some other folder; and also, if the message is in the Inbox, the next time a Get New Messages action is taken.  (This behavior is even more complicated when using an IMAP account.)  And of course, when you start the program up, there are no "new" messages, even if there were new ones when it was last closed.


> Alternatives to this would be:
> 
> 1) Flag the existence of unread messages at the top level mail/newsgroup 
> folder level for each account

As stated: New message arrival is indicated at the top level account node, altho this flag does not mean "account contains new messages."


> 2) Provide a toolbar global indicator (flashing icon, text or other) 
> that some folder has unread messages. This would allow the account 
> folder to remain closed and thus shorten the list.

I thought the Mac had an equivalent of the Windows "tray icon" -- in Preferences|Mail|Notifications, is there not a third option besides "show an alert" and "play a sound"?  But that icon, at least in Windows, disappears as soon as any account loses its "new" flag.

Doesn't the Mac have some kind of "bouncing icon" that's a standard indicator for new mail?  I don't know if Seamonkey or Thunderbird use this.


> 3) Allow an option for the Mail and Newsgroup / Notifications sound to 
> periodically be played if there are unread messages. This is the least 
> desirable as it may become annoying unless a quick method to clear the 
> indicator (e.g.: toolbar button) is provided.

Again, per bug 210148: under Windows, at least, as long as any account is still flagged New, there are no subsequent alerts, the idea being that one audible/animated alert is sufficient, and if the user missed it while away, when she returns to the computer she can check the tray to see if there's something new.
Given that philosophy, a recurring sound without even any subsequent new mail seems even less likely to go forward.


This is not to say there is no room for improvement, but if you're making suggestions like this you really should have a solid understanding of the existing behavior, including cross-platform issues, and be aware of all the other notification RFEs submitted (and bugs already reported).

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: search
Assignee: mail → nobody
QA Contact: search → message-display

Comment 2

3 years ago
Closing this one due to Comment 2 (I gree).

If the flag for newly arrived messages is missing for MAC a new Bug should be filed for this.

If there are well founded suggestions for additional alarming concerning newly arrived mails also new Bugs for each suggestion should be be filed after a check whether no add-on for this need does exist.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.