Search opens two identical tabs when pressing Enter but only one tab with CTRL-Enter or clicking on "search" button.

VERIFIED DUPLICATE of bug 344189

Status

()

Firefox
Search
--
minor
VERIFIED DUPLICATE of bug 344189
12 years ago
12 years ago

People

(Reporter: Strephon Alkhalikoi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

If you type a search into the search bar and press Enter once, the browser opens up two tabs which contain the same search terms.  Pressing CTRL+Enter or clicking on the "search" button in the taskbar only opens up one tab.

Reproducible: Always

Steps to Reproduce:
1. Go into about:config and set browser.search.openintab to true.
2. Type in a search in the search bar.
3. Press Enter.

Actual Results:  
Pressing Enter once opens up two tabs which contain identical search terms.

Expected Results:  
The expected behavior should mimic Firefox 1.5 in that pressing Enter should open up only one tab with the expected search terms.

Tested in safe mode with all extensions disabled to ensure that an extension was not the cause.  Result was as described in Actual Results.  Bug severity is noted as minor because the following workarounds are possible:

1. CTRL-Enter
2. Search button
3. Closing the extra tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming under windows on branch and trunk.
(Reporter)

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 344189 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.