Closed Bug 344518 Opened 16 years ago Closed 16 years ago

window width depends on status bar text when https is used

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 204743

People

(Reporter: olky, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When the status bar contains secure information the window width will depend on the width of text in the status bar. When you will try to resize that window the resizing window icon (in the bottom right corner) will disappear.


Reproducible: Always

Steps to Reproduce:
1. open firefox 1.5.0.4
2. login to the bugzilla.mozilla.org
3. in the status bar the folowing text will appear: 
Server: Apache/2.0.52 (Red Hat) | bugzilla.mozzila.org | <resize icon>
4. try to resize window by dragging the <resize icon> which in the bottom right corner of the window; 
5. when the window width will be less then width of text in the status bar the <resize icon> will disappear.

Actual Results:  
when the window width will be less then width of text in the status bar the <resize icon> will disappear.

Expected Results:  
<resize icon> should not dissaper. the width of window content should not depend on width of text in the status bar.
Is this the same in safe mode ? (http://kb.mozillazine.org/Safe_mode). You must have an extension to get the text "Server: Apache/2.0.52 (Red Hat)" on the status bar.
Attached image just a screenshot
(In reply to comment #1)
> Is this the same in safe mode ? (http://kb.mozillazine.org/Safe_mode). You must
> have an extension to get the text "Server: Apache/2.0.52 (Red Hat)" on the
> status bar.
> 

Yep, in the safe-mode I see only bugzilla.mozilla.org in the status bar, but this  doesn't help. If the http is used then the status bar doesn't contains additional (secure) text information and all work fine.
(In reply to comment #1)
> Is this the same in safe mode ? (http://kb.mozillazine.org/Safe_mode). You must
> have an extension to get the text "Server: Apache/2.0.52 (Red Hat)" on the
> status bar.
> 


Yep, in the safe-mode I see only bugzilla.mozilla.org in the status bar, but this  doesn't help. If the http is used then the status bar doesn't contains additional (secure) text information and all work fine.
So the bug here is that the resize box is thrown off the window bottom too early when you make the window small ? Note that you can still resize in this case.

*** This bug has been marked as a duplicate of 204743 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
(In reply to comment #5)
> So the bug here is that the resize box is thrown off the window bottom too
> early when you make the window small ? Note that you can still resize in this
> case.
> 

it is true if the page allowes scrollbars. If you try to open window through javascript with the command 

window.open("your secure page", "myWindow", "width=10px,height=10px,scrollbars=no,resizable=no"); 

you will not still able to resize the window.

Also in this situation if the page in the popup window will contain <table width="100%">...</table> the page content will be trancated in the right, because firefox reserve some space for the <resize icon> or something else.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 204743 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.