Closed Bug 344535 Opened 14 years ago Closed 14 years ago

Alarm sound "browse" button crashes Sunbird under Linux [@ nsFileView::SetFilter]

Categories

(Calendar :: Sunbird Only, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: steiner, Unassigned)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

In the Sunbird preferences, under Alarms, there is a "Browse" button to select a custom alarm sound. Clicking this button crashes Sunbird on Linux.

Reproducible: Always

Steps to Reproduce:
1. From "Edit" menu, select "Preferences"
2. Click "Alarms" tab
3. Click on "Browse..." button in the "When an alarm goes off, play a sound" area

Actual Results:  
Sunbird crashes.
When run from a shell, STDOUT receives:
.../sunbird/run-mozilla.sh: line 131: ##### Segmentation fault "$prog" ${1+"$@"}


Expected Results:  
Some sort of "Choose sound" graphical file selection window should pop up.

Sunbird 0.3a2 on KDE 3.3.1-3.14 Red Hat, Linux version 2.6.9-34.ELsmp (buildcentos@build-i386) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2))
Pentium 4 3GHz, 1 GB RAM
Which nightly version of Sunbird are you seeing this in?
In addition, which distro and version of Linux?
Sorry that I didn't notice your OS and version info at the bottom.

Could you please try and reproduce the error with the latest nightly?
There has been large amounts of work done on the preferences since 0.3a2 was released.

Thanks
WFM on Mac, a stack-trace here would be awesome.
Sorry, I'd picked up the version dated from May 15.

Went back for the nightly and tried again, but the error occurs as before... Does the code sample from STDOUT point to the source of the bug in a meaningful way?

(In reply to comment #2)
> Sorry that I didn't notice your OS and version info at the bottom.
> 
> Could you please try and reproduce the error with the latest nightly?
> There has been large amounts of work done on the preferences since 0.3a2 was
> released.
> 
> Thanks
> 

(In reply to comment #4)
> Does the code sample from STDOUT point to the source of the bug in a meaningful
> way?
Unfortunately no.  Right now, the only way to get truly meaningful data out of Sunbird is to build it yourself with --enable-debug.  This will keep all the symbols in the build and allow for a detailed crash report.  (I talked with Jay last night about getting Talkback for Sunbird, but that's still a ways off.)
Works for me with old preferences using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2.

Works for me with new preferences using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060713 Sunbird/0.3a2+.
Works for me with Ubuntu:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060713 Sunbird/0.3a2+.


Talkback is now available.  Reporter, if you could get a new nightly build and reproduce this crash, it will now send the data we need.
I *think* this is TB22494055.
According to bug 257427, we should probably be using some Components.interfaces.nsIFilePicker.filterAll love here prior to init().
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: Alarm sound "browse" button crashes Sunbird under Linux → Alarm sound "browse" button crashes Sunbird under Linux [@ nsFileView::SetFilter]
Attached patch patch per Joey's suggestion (obsolete) — Splinter Review
Attachment #236851 - Flags: second-review?(jminta)
Attachment #236851 - Flags: first-review?
Attachment #236851 - Flags: first-review? → first-review?(mattwillis)
Comment on attachment 236851 [details] [diff] [review]
patch per Joey's suggestion

>+        //XXX Set filter for all file types here so we don't crash
>+        fp.appendFilters(nsIFilePicker.filterAll);

I'm not sure if we need to append a comment here (since we have cvs blame), but if jminta thinks we should have one, I'd replace "XXX" with "Bug 344535: " so we can refer back to this issue.

Otherwise, r1=lilmatt
Attachment #236851 - Flags: first-review?(mattwillis) → first-review+
Comment on attachment 236851 [details] [diff] [review]
patch per Joey's suggestion

Yeah, let's save XXX comments for things that actually need to be fixed/replaced later.  It's not clear to me that the appendFilters line should really be removed later. r2=jminta with that.
Attachment #236851 - Flags: second-review?(jminta) → second-review+
Patch (w/ nit) checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Cool. Here's an updated patch for checkin. Ingmar, if you could verify that this fixes things once it gets in the tree and new builds go out, that would be great.
Attachment #236851 - Attachment is obsolete: true
Attachment #236960 - Flags: second-review+
Attachment #236960 - Flags: first-review+
D'oh. Thanks, Matt.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsFileView::SetFilter]
You need to log in before you can comment on or make changes to this bug.