gContextMenu.searchSelected does not return any text

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: leftie.friele, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

I have written a simple extension which retrieves the selected text and opens a new tab. 
The extension work well when I installed it 3-4 times. But after FF crashed, due to reasons I don't know the gContextMenu.searchSelected() does not return any text. 
The extension runs perfectly with the 1.5 instalation, but in FF 2 beta 1 it just wont work anymore. I am not sure if this is due to some error installing my extension or if there is some other bug causing this. Maybe it is related to the crash I had previously.

Reproducible: Always

Comment 1

12 years ago
I'd also developed a FF extension using a gContextMenu.searchSelected() call, which worked fine until (including) FF 1.5.0.7. With FF2 it does no longer! :-(((
The "Firebug" debugger tells me while attempting to perform the corresponding Javascript code that "gContextMenu.searchSelected() is not a function"...

Comment 2

12 years ago
You can use browser.js function getBrowserSelection(aCharLen) as a replacement, where the string returned will be 0 to aCharLen characters in length, to a maximum of 150 chars.

This bug is probably invalid, unless there's any particular reason to still support the old method.
At this point, yeah, there's no point in having 3.0 support a function name from 1.5 that 2.0 didn't have. At some point, though, we may have to start treating browser.js functions as semi-frozen APIs, and translate calls to the old name into calls to the new, as best we can (since sometimes it's just s/Crappy name/Good name/ and sometimes it's s/Crappy function with bad params/Good function with sane params/).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.