Cannot upgrade my PostgreSQL installation anymore

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Installation & Upgrading
--
blocker
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

2.23
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment)

849 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
I cannot upgrade my Pg installation anymore since mkanat's patch from bug 281494 has been committed:

checksetup.pl: Your PostgreSQL v08.00.0800 is too old.
checksetup.pl:    Bugzilla requires version 8.00.0000 or later of PostgreSQL.
checksetup.pl:    Please download and install a newer version.

Backing out this patch fixes the problem. So either back it out from CVS or fix the problem.
(Assignee)

Comment 1

12 years ago
OK, looks like the problem is that:

my $sql_vers = $dbh->bz_server_version;

returns 08.00.0800 and for some reason vers_cmp() sees it as smaller than 8.00.0000 because 08.00.0800 begins with a "0" while 8.00.0000 begins with a "8" and everybody knows that 0 < 8.

To make sure this was the problem, I added:

$sql_vers =~ s/^0*(.*)$/$1/;

right after the line above and this fixes the problem. So probably vers_cmp() has been changed while being moved into Requirements.pm.
(Assignee)

Comment 2

12 years ago
Created attachment 229256 [details] [diff] [review]
patch, v1

The maintainer of Sort::Versions admitted per email that it should handle this testcase correctly. He said he was going to make a fix. Here is the fix I suggested.
Assignee: mkanat → LpSolit
Status: NEW → ASSIGNED
Attachment #229256 - Flags: review?(mkanat)

Comment 3

12 years ago
Comment on attachment 229256 [details] [diff] [review]
patch, v1

Sure, that looks right to me. Note in the comment that it's a fix for this bug number, so that it doesn't ever get accidentally removed.
Attachment #229256 - Flags: review?(mkanat) → review+

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 4

12 years ago
Checking in Bugzilla/Install/Requirements.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Install/Requirements.pm,v  <--  Requirements.pm
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Blocks: 344915
You need to log in before you can comment on or make changes to this bug.