.s files need to be correctly relicensed

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Details

Thanks to an email from a Debian developer, I have found an obscure part of my relicensing script which makes it entirely skip files with a ".s" extension:

    if ext == ".s":
        # '.s' file comment delimiters are all over the map.
        log.info("Skipping '%s' ('.s' files are wacky)", path)
        return 1

The comment delimiters are wacky, because each platform-specific assembler appears to have defined its own comment character :-( I need to relicense all the .s files by hand.

Gerv
*** Bug 360933 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Blocks: 360933
This is now fixed on the trunk - although it may take some time for projects using these files to use the new ones, if they have a separate release schedule (e.g. NSS).

Gerv
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.