If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

incorrect row spacing in tables

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Ken Yee, Assigned: buster)

Tracking

({testcase})

Trunk
Future
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3-], URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; NT4.0; en-US) Mozilla/m13
BuildID:    2000022820

On the agn3d site, look at the menu on the left; all the lines are scrunched
together.
On the 3dnews site, the lines on the menu to the right are spaced too far apart.
Otherwise, this build looks a lot cleaner than M13.


Reproducible: Always
Steps to Reproduce:
1. see above
2.
3.


Actual Results:  row spacing incorrect

Expected Results:  compare w/ Netscape results on two sites

Comment 1

18 years ago
Could you please download a recent nightly build from <ftp:
//ftp.mozilla.org/pub/mozilla/nightly/>, and then let us know if you still see
this problem?

I could not reproduce the problem with 2000050820 on WinNT

Thanks,

Bernd

Comment 2

18 years ago
Finally I have seen it with win98
Keywords: makingtest

Comment 3

18 years ago
Created attachment 9566 [details]
testcase for the problem at www.3dnet.com

Comment 4

18 years ago
The www.agn3d.com problem is also caused by version sniffing, see the source of
the left frame. So I believe this part of the bug is invalid. The www.3dnews.net
shows a problem on the left side as described in the original report. The
testcase should give vertically aligned bullet, but it is shifted downwards.
Keywords: makingtest → testcase

Comment 5

18 years ago
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

18 years ago
Buster, when I dumped frames in the attachment, I saw that the text "blank" was 
substituted for the <img> causing the 2nd row to be taller than the specified 2 
pixels in the <img>. When I brought the file locally, I wasn't able to get the 
same behavior.
Assignee: karnaze → buster
(Assignee)

Comment 7

18 years ago
This was a 5-minute fix.  Neither Nav nor IE use the "SRC" attribute as alt 
text, so I made that true for MOZ in quirks mode as well.
Nominating for nsbeta2 based on having a safe, simple fix that will make us more 
compatible.
Status: NEW → ASSIGNED
Keywords: 4xp, nsbeta2
Whiteboard: [fix in hand]
(Assignee)

Comment 8

18 years ago
Created attachment 10015 [details] [diff] [review]
FIX: made use of SRC attr only in standard mode
(Assignee)

Comment 9

18 years ago
Chris:  actually, I only fixed part of the problem.  The 3dnews site is still 
wrong because the first cell in the row is breaking oddly.  I don't know if this 
is a table, text, or layout bug.  But I know I won't get to it this week.

If you review the partial fix I have attached, I'll check in that fix at least.
Assignee: buster → karnaze
Status: ASSIGNED → NEW
Whiteboard: [fix in hand] → [partial fix in hand]
(Assignee)

Comment 10

18 years ago
Created attachment 10016 [details]
test case that shows the odd breaking behavior in the first cell, somehow dependent on the second row in the table. The second table has only 1 row, and it lays out correctly

Comment 11

18 years ago
Putting on [nsbeta2+][w/b minus on 6/22] radar.  Check in the partial fix you 
have.  Can do rest in nsbeta3.
Keywords: nsbeta3
Whiteboard: [partial fix in hand] → [nsbeta2+][w/b minus on 6/22][partial fix in hand]

Comment 12

18 years ago
Cleaning up status whiteboard and marking beta2 minus (6/22 has passed)

Reading the comments, it sounds like the partial fix has already been checked 
in... and hence the additional text (re: parfial fix in hand) in the whiteboard 
should be removed.  I'm guessing I understood correctly, and I'm removing it. 
(I'm guessing that fix was checked in... correct??)

The summary should probably also be adjusted to indicate that the problem is now  
"first row has ..." 

Please consider updating the summary, or creating a new bug for this more odd 
case.

Thanks,

Jim
Whiteboard: [nsbeta2+][w/b minus on 6/22][partial fix in hand] → [nsbeta2-]

Updated

18 years ago
Assignee: karnaze → buster

Comment 13

18 years ago
Buster, the problems I see with the 3rd attachment are (1) in the 1st table 
mozilla prints "blank" whereas Nav honors the height of 2 pixels and does not 
print "blank" and (2) in the 2nd table the line is too tall probably because of 
the special character.
Ian - cc: so you know about alt. text issue here.
buster: The handling of 'src' is going to be changed in nsbeta3, see bug 41924.

Comment 16

17 years ago
Denying approval for beta3.
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
Target Milestone: --- → Future

Comment 17

17 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001022620

Looks exactly the same in Mozilla and IE in the testcases and the websites.
Reopen when/if this reoccurs.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 18

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 19

16 years ago
 
 Fixed verified on Build ID: 2001082008
Platform: WIN2K
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.