Character enconding doesn't work correctly

RESOLVED DUPLICATE of bug 315381

Status

()

--
major
RESOLVED DUPLICATE of bug 315381
12 years ago
12 years ago

People

(Reporter: luis6674, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Firefox/1.5.0.4

I've seen other bugs filed related to character enconding so it could be related to some of them. However, none seems confirmed so far, so:

The Charset doesn't work correctly in Firefox 1.5.0.x. It did work in 1.0.x, though.

My default charset is iso-8859-1 (western european). If I click view>characer encoding the correct one is selected. But to REALLY use it I have to select it manually so the page is reloaded with the correct enconding. This happens in all 1.5 series in both windows and linux. It didn't happen in 1.0, as I said.



Reproducible: Always

Steps to Reproduce:
1. Set ISO-8859-1 as your defaul encoding (if you haven't). Go to a yahoo mail account (other webmail accounts may be valid, but didn't try). Compose a new mail that contains non-english characters (for example, ñ,á,é, etc..) Check in View>Character enconding. ISO-8859-1 should be selected.
2. Click the attach file button and attach a small file. Check in View>Character enconding. ISO-8859-1 should be selected.
3. Return to message and see that those characters are corrupted. Check in View>Character enconding. ISO-8859-1 should be selected.

Second option to correct the problem:
1. Go to a yahoo mail account (other webmail accounts may be valid, but didn't try). Open a compose new mail window. Check in View>Character enconding. ISO-8859-1 should be selected. However, select it again so it reloads the page. Compose a new mail that contains non-english characters (for example, ñ,á,é, etc..) 
2. Click the attach file button. Check in View>Character enconding. ISO-8859-1 should be selected. However, select it again so it reloads the page (say yes if it asks about reloading data, etc...) Attach a small file an
3. Return to message and see that those characters are NOT corrupted this time. Check in View>Character enconding. ISO-8859-1 should be selected, as before.
Actual Results:  
Characters get corrupted.

Expected Results:  
Characters should display fine.

Comment 1

12 years ago
I forget what bug this was changed in but from what I recall in 1.0 encoding auto detection was enabled.  But in 1.5 it is turned off due to problems with it.  Does changing auto detect to universal result in behavior like 1.0?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Does changing auto detect to universal result in behavior like 1.0?
> 

No, that doesn't solve the problem. Only re-selecting the already selected charset seems to do the trick.
(Reporter)

Comment 3

12 years ago
I checked with other web based emails (hotmail and gmail) and those ones work correctly. Only Yahoo seems to have the problem. However, I tried in yahoo again with Firefox 1.0.4 and it does work correctly in Yahoo, so the problem seems to be in both the way Yahoo sends the character encoding and the way Firefox 1.5.x handles it.

I'll try to contact Yahoo about it too, in case they can do something about it.
This was fixed for 1.5.0.5

*** This bug has been marked as a duplicate of 315381 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.