Closed Bug 344760 Opened 14 years ago Closed 14 years ago

Spell checker should choose the right language

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 338427

People

(Reporter: u49640, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

i often write messages in different languages. (german and english)
it would be great if the spell checker could somehow find out the language of the page and switch the spell checker to the correct one.

i don't know if this is technically possible (or easy) but maybe even something that simple as having a list with
tld == de || at -> german spell checker as default (if installed)
would do it for most sites. (obviously it wont work for generic tlds like com/net/org/...)

Reproducible: Always

*** This bug has been marked as a duplicate of 338427 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.