When saving web pages to disk, their original URL is NOT saved.

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Derek Bousé, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When using the 'Save Page As' feature to save web pages to disk, the saved page has no reference to the original location or URL of the source page.  Instead, the navigation bar at the top now refers only to the "local host" location on the computer, NOT to the original URL.  This makes future citation of the saved article impossible.

Reproducible: Always

Steps to Reproduce:
1.  Save any page at any newspaper site.
2.  Use the "save page as" command, or 'command-S'
3.

Actual Results:  
Instead of the original URL being saved in the navigation bar at the top, all that appears there in the saved page is the saved document's  'address' on the hard drive. 


The original URL should be permanently saved, so that in the future, when the saved document is opened for offline reading, the original URL appears in the Navigation Bar.
The location bar displays the address of the page you are viewing. Since the page is on your disk is should display that address.

Firefox does not yet offer offline browsing, and if it did the method would be to bookmark the page, not save it locally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.