scrolling immediately after opening a new unfocused tab affects new tab scroll position

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: grick.sigger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Scrolling immediately after opening a new unfocused tab (with middle-clicking) affects the scroll position of the new tab, even though it was never focused.

Reproducible: Always

Steps to Reproduce:
1. Ensure prefs are set so that middle-clicking a link opens it in a new unfocused tab in the same window
2. Middle-click on a link
3. Use scroll wheel to scroll down (or up)
4. Stop scrolling and go to the new tab (which has never had focus)
5. Observe scrollbar position
Actual Results:  
scroll position of new tab is affected (not at the default/top)

Expected Results:  
scroll position of new tab should be unaffected (at the top, usually), because it was never focused at any point
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Please retest with disabled extensions or with a new profile.
(Reporter)

Comment 2

13 years ago
Hm, must be an extension. Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
Hm... I only seem to be able to reproduce this on GameFAQs Message Boards.
(Reporter)

Comment 4

13 years ago
Sorry for the bug + multiple posts; I was unable to reproduce on a new profile.
You need to log in before you can comment on or make changes to this bug.