Leak when changing external graphics viewer

RESOLVED DUPLICATE of bug 341872

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 341872
12 years ago
12 years ago

People

(Reporter: Flummox, Unassigned)

Tracking

({memory-leak})

Trunk
x86
All
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060714 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060714 BonEcho/2.0b1

When a link leads to a tiff file I am prompted to choose an external graphics viewer. If I change from the option which is preselected there is a leak alert displayed by Leak Monitor.

Reproducible: Always

Steps to Reproduce:
1.Click a link leading to a tiff graphics file (see URL)
2.Choose a different viewer from that which is already selected
3.

Actual Results:  
Leak Monitor displays an alert


On my system the default viewer is Eye of Gnome and my alternate choice was Kuickshow. The leak only happens when switching from one to the other.

Comment 1

12 years ago
I see it also on 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060717 BonEcho/2.0b1

but I don't see it on trunk.

Comment 2

12 years ago
Created attachment 229512 [details]
leak log

Comment 3

12 years ago
My bad.  It would help if I used my trunk profile with leak monitor.  ;)

Confirmed same leak with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060717 Minefield/3.0a1 ID:2006071704 [cairo]

Next is the duplicate question.
OS: Linux → All
Version: unspecified → Trunk

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 341872 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: mlk
Resolution: --- → DUPLICATE
Summary: Leak when changing external graphics viewer - mlk → Leak when changing external graphics viewer
You need to log in before you can comment on or make changes to this bug.