Page loads very slowly, 100% CPU usage

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Konstantin Svist, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The page is about 300kb in size (pretty big for a page of this type, granted). It takes about 30 seconds to load on my laptop (Athlon M 2400+, 1GB ram, no page file).
While the page is loading, the CPU is spiked to 100%. <guess>I'm guessing the renderer thread has same or higher priority than downloader thread, so rendering is interfering somewhat with downloading</guess>

Loading the source code of the page (View Source) results in similar CPU hoggin and takes about as long to load the source. In comparison, using a download manager the page is loaded almost instantly (no rendering there, of course).

I have some slow extensions installed, but the same behavior appears in my other Fx profile with no extensions (only dom inspector and talkback).

Reproducible: Always
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060717 BonEcho/2.0b1 
I see this also when I go to that site with my extensions enabled, but it loads a lot faster when I disable them. So possibly this is an extension problem and in that case it should be taken up with the extension author.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
Will definitely do that - but the page takes ~15 seconds to load with clean profile. Is this normal?
It loads within seven or eight seconds here and that is not much more than the time IE needs to load the site.
(Reporter)

Comment 4

12 years ago
Since when is IE the official benchmark for Firefox?
In Opera (clean install) it goes much faster
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060726 Minefield/3.0a1

Page loaded in 3-4 seconds for me. Tested with a similar, pentium-based laptop. The fact that you have no page file scares me: Virtual memory never hurt anyone.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Page loaded in 3-4 seconds for me. Tested with a similar, pentium-based laptop.
> The fact that you have no page file scares me: Virtual memory never hurt
> anyone.

If you have a relatively new machine, 3-4 seconds is reasonable - but on my old 2400+ Athlon M laptop takes more than 30 seconds, which is pretty bad.

As far as the page file: virtual memory is great, and you can't turn it off anyway. Paging file, on the other hand, is a nuisance to me in Windows. In Linux it works as it's supposed to, but in Windows it keeps swapping pages for no good reason, using the HD too much. With 1GB of ram, I don't need a page file anyway - I sometimes reached the limit when I had 512M and I would open Photoshop and Dreamweaver and/or Firefox at the same time - but it's worked wonderfully since I got 1GB. Highly recommend any Windows userwith normal memory requirements at 1GB+ of actual ram :)
(Reporter)

Comment 7

10 years ago
Well, it's been a while since Fx 1.5, and 3.0 is almost here. I'd love to check on the progress - but the dell.com page is gone now..
I see some slow-loading pages, but none are as bad as 30sec anymore.
Closing the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 8

10 years ago
If the page is gone, the resolution should be incomplete. Wontfix is for developers to set policy.
Resolution: WONTFIX → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.