IMAP slow to mark message as read, not marked as read unless entire message downloaded

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: pookey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patchlove][needs owner])

Attachments

(1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.3 (like Gecko)
Build Identifier: version 1.5.0.4 (20060516)

If I have a mailbox with 30 messages, and tap 'N' quickly to scroll though 10 messages in the box, then not all will get marked as read, perhaps only 6 or so.  I imagine it's because it's having to load the email from the server everytime I select it, which takes longer then it takes me to hit 'N' again.

http://forums.mozillazine.org/viewtopic.php?t=440204&highlight=

Reproducible: Always

Steps to Reproduce:
1. go to mailbox with X number of unread mails
2. press 'N' Y number of times ( where Y  < X)

 
Actual Results:  
number of unread messages != X - Y

Expected Results:  
number of unread messages == X - Y

do not have 'mark read after X' enabled.
IMAP over SSL
Cyrus backend
Fast DSL connection

Comment 1

13 years ago
A message seems to be marked read only when its fully loaded.
(Reporter)

Comment 2

13 years ago
yeah - this is a real pain IMO.  Considering tbird is able to be getting these messages in the background, surely it can mark as read in the background?

Thanks!

Comment 3

12 years ago
Does problem still exist in thunderbird 2?
Johannes, do you also see the problem?
Version: unspecified → 1.5
(Reporter)

Comment 4

12 years ago
Yes, still a problem - Tbird 2.0.0.4

Comment 5

11 years ago
Carsten, do you see this on linux?
WFM 2.0.0.7pre, windows, both unchecked, and set to zero.
(Reporter)

Comment 6

11 years ago
still a bug in linux with 2.0.0.6.

on very fast connections this might not be noticable, it's certainly noticable on my DSL though
OS: Linux → All
Version: 1.5 → 2.0

Comment 7

11 years ago
devs

Should this work differently if value is 0 or unchecked?   Probably by design as postulated in comment 0 and 1.  there are so many "mark read timer" bugs that I didn't have time to wade through them all to find a dupe.

(I see on slower link (cablemodem, comment was gigabit) version 2.0.0.6 (20070728) with delay 0 or unchecked.)
Summary: IMAP folders slow to mark as read → IMAP slow to mark message as read, not marked as read unless entire message downloaded
Version: 2.0 → 1.5

Comment 8

11 years ago
Confirming. Still a problem in recent trunk builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

11 years ago
Created attachment 307291 [details] [diff] [review]
Mark messages read immediately

Currently IMAP messages are marked as read automatically by the IMAP server when they are fetched (I think), and newsgroup messages and messages in local folders (usually fetched from a POP server) are marked as read when the messages has been fully loaded and the load event occurs. This bug exists for all three types of messages.

With this patch, messages are marked as read immediately.

Comment 10

11 years ago
I guess the marking in OnMsgLoaded should be removed for the mailnews.mark_message_read.delay == 0 case, but I am not sure that the place I have patched is the only place where message loads are initiated.
Assignee: mscott → nobody

Comment 11

10 years ago
Christian, you will want to check that the patch is still good, and set a reviewer.

Updated

10 years ago
Severity: normal → minor
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.imap
Hardware: Other → All
Whiteboard: [patchlove][needs owner]
Version: 1.5 → unspecified
Wouldn't this be WFM now, since imap operations are played back in the background?

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Whiteboard: [patchlove][needs owner] → [patchlove][needs owner][wfm?]
Comment on attachment 307291 [details] [diff] [review]
Mark messages read immediately

Patch is obsolete. File at mailnews/base/resources/content/msgViewNavigation.js no longer exists.
Attachment #307291 - Attachment is obsolete: true
-> WFM per comment #12.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(In reply to comment #13)
> (From update of attachment 307291 [details] [diff] [review])
> Patch is obsolete. File at mailnews/base/resources/content/msgViewNavigation.js
> no longer exists.

It has just moved:
/mail/base/content/msgViewNavigation.js
/suite/mailnews/msgViewNavigation.js
Whiteboard: [patchlove][needs owner][wfm?] → [patchlove][needs owner]
You need to log in before you can comment on or make changes to this bug.