Hints are persistent when under dock.

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Jon, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

My dock is on the left side and hidden, with magnification. Firefox places its top window against the left edge of the screen. Here's what happens: I mouse to the left edge to look at my mail icon (for the message count). The dock appears and the mail.app and other icons magnify. I hover over the mail icon, which happens to be over the first item on the bookmarks toolbar. Hovering causes the Firefox hint to appear. If I then click on the mail.app icon, the hint will persist and remain on top. It can only be removed by making Firefox the top window.

The hints should disappear if Firefox is not the top window.

Reproducible: Always

Steps to Reproduce:
1. Dock on left side, hidden with magnification. Firefox open and on top, with bookmarks toolbar. 
2. Mouse to icon on dock that happens to be over bookmarks toolbar. Hover over icon (and bookmark) until hint appears.
3. Click on icon in dock. That app should activate on top. 

Actual Results:  
Firefox hint should disappear, but doesn't.

Expected Results:  
Firefox hint should disappear.

Since the hint covers valuable upper real estate on the screen, I'm always forced to go back to Firefox to get rid of it. That's what elevates this bug from minor to a normal bug that should be fixed. (IOW, it's a real PITA.)
(Reporter)

Comment 1

12 years ago
131758 is similar to this. (It's been around for years!)
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.